Low Poly UV Unwrapping

I’ve been messing around with UV unwrapping for a while now trying to get decent shadows, but I’m pretty sure I’m doing it wrong / badly. My models are all going to be low poly like the one attached, does anyone maybe have any tips as to how I can do it better? I’ve just about managed to stop light bleeding through edges but ideally I want to get much sharper shadows on the model. Upping the lightmap resolution doesn’t help and I’ve played around with the world light settings to not much effect.

Any ideas for more defined shadows?

Thanks for any help!

You have a smoothing issue, but you can also improve your lightmap UV’s, no need to separate as many parts, you can do a seam down one side and it should flatten out.

Try using Cascaded Shadow Mapping to get a more defined shadow on your trees.

Thanks, this needs to run on mobile so I think that rules out cascaded shadow maps?

Splitting it into only 2 or 3 parts with one seam down the side gives me bleed on every edge as below - is that a smoothing issue? I have set every face to flat shaded and marked edges as sharp in Blender, is there something else I should do?

Also, this is all static baked lighting (as for mobile).

hi all,

it seems I occure the same issue with my shadows (so I post here, hoping it doesn’t bother you Doug…)

here’s my problem :


any idea of what i do wrong ?


Hi Everyone -

Remember that if your shadows are close but blocky after the light build, to run the light build using Production instead of Preview Quality. It will take longer but the quality is markedly improved as well. From what I am seeing here (beside the already mentioned lightmapping tips) seems the most likely cause.

Movable will mean that the light only casts dynamic shadows, change it to Static/Stationary, and you will probably have to increase your lightmap resolution.

the render you see on my screenshot was built in production quality.
I tried different settings for the LightSource, movable gives the “best” result. For static and stationary, even if i go crazy with the lightmap - 1024 or 2048, I occur splotchy and bleeding shadows. I know those bleeding issues are mainly caused by an unefficient unwrapp, small padding beetwen islands, etc…but in this particular case, the way I unwrapped my model seems good to me. Of course, i might be wrong…what do you think ?

You might not have the correct settings on your mesh, maybe it’s not set to use the correct UV channel for the lightmap or you aren’t setting the right setting that will change the lightmap resolution.

If you have more questions, start a thread though, so that this one doesn’t get derailed.

I spent ages a while ago trying to get baked shadows to look good on low-poly modelling (with no smoothing) and in the end the only way I managed to get it to look good was light-map resolutions through the roof

You can change the visualisation to view the density of the lightmaps and I individually tweaked each object to high densities (from memory like 2000-4000) and finally got it looking ok. Build times were ridiculous and simple levels had hundreds of MB of data in the lightmaps

I ended up caving and ditching baked lights for my low-poly maps. the LPV (you have to enable it by editing an .ini) works really well and the only downside really is the inability to target OSX

You don’t need to have sharp edges in Blender when doing low-poly stuff, because when you export as an .fbx you should turn off smoothing altogether

Self shadowing is also an issue and I could never find a right bias value to stop self shadows from looking bad while also being where they should be

Thanks for the input, I’ve now got the look I wanted by altering the Static Level Lighting Scale - I’ve done some tests and the file size and performance on mobile seems to be identical. Having it set to 0.1 gives me the defined shadow lines I was after and eliminates light bleed.

Perhaps someone can shed some light on setting this to 0.1, even though everything in my level is to scale? Can’t find much info on it anywhere.

Did you edit or change your post?

Anyway, glad you found a fix! Where is that setting?

I’m still doing low-poly in my game, I’ll likely want to know soon how to do it!

Also, perhaps a redundant tip but a small amount of fresnel in your shaders can add a fair amount of depth :wink:

I did, to post my own solution instead of a load more questions!

It’s in world settings > lightmass > static lighting level scale.

It’s quite a unique look and may as yet introduce other problems, I’m happy with it though. I did experiment with fresnel a bit, I may give it another try now though thanks for the tip.