Download

Low FPS warning changed my settings. What to do?

4.11
Help needed. During material compilation something I’ve not seen before appeared - low fps warning with a percentage of how many frames were under 30. Some 4 seconds later I saw a counter that said something about changing the quality settings automatically to “help” me with performance. I did not manage to click cancel in time. And the thing changed the quality settings in-editor. Now, no matter what settings I choose in Engine Scalabilility (everything set to max) I can’t get good TemporalAA or maybe even some other things that I’m not seeing yet. Changing AA setting in the main Unbound PostProcess Volume does not help for the in-editor visuals either.

What do I do know? I have not idea how to get my AA back to what it was, I don’t know if any other settings have been altered as well.

P.S. And for the future, how do I disable this atrocity? Is it the “Monitor Editor Performance” thingy? Never thought “monitor” means “change at will in 4-or-so seconds”. I don’t need software to think for me, really. I was working in another app simultaneously and was well aware of the performance issues it might incur. IMO, this hand-holding is unnecessary and has stopped my work now.

Solved
Had to delete the contents of the Saved/Config folder of my project to get settings back to normal. The question of how to disable it still stands though.

Go to:

Edit -> Editor Preferences -> Miscellaneous and un-check the setting named “Monitor Editor Performance”

That’s the first thing I disable when starting a new project. On my system it runs at 3fps when using another program (or while saving) and the editor mistakenly triggers the warning.

For future reference, if it happens again just click the Settings button on the toolbar, go to Engine Scalalbility and set all of the options back to Epic quality. That’s all that happens when you click ok on the warning, it just gets set to low or medium.

Thanks for answering, but:

I’ll just quote myself:

That’s the first thing I did. Everything on Epic, but AA was still not good. Something’s off here. In Play mode AA was good, but in Editor it remained subpar. Had to delete Saved/Config. And another thing: doesn’t it change the settings automatically, without me clicking “OK”?. Though I suppose I could’ve accidentally clicked it.

Hi,
i am new to UE4. Got this issue wich resemblance me this one described in post. Actually i clicked the low fps warning to change settings for lower details after running project launch. Still can’ t solve it and make it work like for first time. I even tried to reinstall whole engine. First time running there was shader wich made footprints visible on the floor. Now can’t see it at all. I changed whole settings to cinematic, material to high. And no shader pop up window shows when pressing launch , like first time was (and the foot prints) or like on other template projects. Please help

hi
iam new comer

Hi dudes .
i tried to make some grass on the field but that make my fps about 10 or less and i saw notificatin that told it is better to change my setting an i accept it . then i don,t see the grass . how can i change setting back. can you describe more
sincerely
H . Marvi

literally 90% of answers to all your questions can be found if you search the ue4 documentation