Download

Loss of metallicity and roughness when using transparency

Not sure why, but I’m losing the inputs for my roughness and metallicity when I change it from opaque to transparency. Anyone have any suggestions? I’m using 4.11.

Is you material using the Unlit shading model? You will need Default Lit for access to those inputs. :slight_smile:

Yeah, here’s a screen cap of just changing it from opaque to translucent. Can hardware affect this?

weird.jpg

Set Lighting mode under Translucency to Volumetric Directional or Surface

If I set to Volumetric Directional I lose the Metallicty and Roughness. The Surface works but I have an alpha order problem with it drawing parts of the mesh over itself in the foreground.

Translucency was a problem in forward ue3, but in deferred ue4 everything become even worse. So just try to avoid it for complex shapes. In some cases dithered masks may be acceptable alternative.

Change the Translucency setting to Surface, and check ‘Screen Space Reflections’.

The parameters are useless without those settings anyway.

Also if the objects need to render in a certain order, you can set the sorting order for the object once it is placed in the level. Select it in the viewport and then in the Rendering tab of the Details panel, expand all of the settings until you find Translucency Sort Priority. Higher numbers will render in front if lower priority objects. Here’s a bit more info:

I think you can also select ‘seperate translucency’ or something so it’s not in the translucency pass. Which will help with the draw order thing