Download

Loosing FPS when SkyLight is on movable

I am under the unreal 4.9 version I have Mesh distance field on. Windows 10 and -DX12 on (I try to disable it by running -DX11 command but I don’t know if it’s work soo).
When I put my bluprint for the time of day system I loose 45 FPS… Have you any ideas?

Whith sky light movable :

Whith skyLight statinary (soo Distance field AO off) :

Thank you per advance !

Charles200000

Hard to tell because your lighting is broken. Try re-building your lighting and see if that fixes your FPS issues.

I have build the lighting but it change nothing :mad: …

Any ideas…

I personnaly thing it maybe because of distance fields AO, because when I go to medium to the engine scability settings I got 120 fps…

At the begin I was thinking that because I convert 4.8 project to a 4.9 project (because in the 4.8 I got 120 fps in ultra mode) but I recreate a project from scratch and nothing change… :mad:

try disabling the raytraced shadows in the directional light

for more debuging right the folowing stat in the console : profilegpu
and post the result

This is definitly the distance field AO who are the cause of this problem I disable the raytraceshadows and that change nothing soo I delete the sky light and all work normaly…
The problem come from the skylight and when I put the skylight to stationary mode all work… :mad:
I run the profilegpu and here it’s the result :

It came from lighting… :

Soo the skylighting got a pb :

The proble is mesh irradiance and AO soo how I can fix this ?

Please help me I need distance field AO in my project !!!

Thank you per advance :slight_smile: .

try disabling the HFGI in the show flag if you’re using a landscape because it says Heightfield irradiance

Yeah I have disable it and all work normaly soo the problem is HFGI.

How I can repair this problem?

It’s not a problem that can be fixed. Advanced features sometimes need a lot of performance.

yes Daniel (the creator of DFAO And HFGI ) said that he stopped the developement on HFGI and with improvements of Dfao in 4.9 the cost of HFGI have growed up

soo the solution is to uncheck this "

until it’s became more acceptable

Hope i helped you have a good day

Ok I will try this tomorrow and say you if that work…

Thank you all for your help !!! :wink:

Daniel, not Ryan, as far as I know :slight_smile:

Sorry but that still change nothing to the problem I have disable the landscape real time GI but I still et 15 fps…
But when I have disable the distance fild mesh AO all go well and I get 120fps…

Still no ideas ?

Yeah Sorry thanx i was disturbed

for the problem disable it from the show menu if you want to disable it in the game there is a console variable but i dont remember it

If the problem is DFAO performance perhaps check “Occlusion Max Distance - Maximum distance from an occluder to compute occlusion contribution. Raising this value will increase the cost of Distance Field AO, but allow occlusion from further away.” ( Distance Field Ambient Occlusion | Unreal Engine Documentation )

From the Docs as well:

*"Performance

The cost of Distance Field AO is primarily GPU time and video memory. In a fairly large Fortnite level, with the camera still, it costs 3.5ms on a Radeon 7870 at 1080p resolution. The worst case when the camera is rotating rapidly is ~6ms. For reference, SSAO costs 1ms with this setup. ~150mb of distance field volume textures were used.

Shading is done adaptively, so flat surfaces and surfaces that are not moving have a lower cost. Conversely, scenes with many small surfaces like foliage, and many things moving between frames will have a higher GPU cost.

The primary cost of Distance Field AO is from object density, as each object must be considered separately for occlusion. A dense forest with many nearby trees will be the worst case for the technique. "
*
Also: “The main factor on quality is effective distance field resolution. This can be modified with DistanceFieldResolutionScale.”

If you turn off DFAO completely then you can have a moveable Skylight as you mention. Do you need DFAO? Could you turn off mesh distance fields completely?

I’m still very new to UE4 so that’s just some thoughts I have at the moment. DFAO is cool but it is a high-end feature that does use up a lot of resources.

Sorry srmojuze but these info are old here are the new

it’s been improved in 4.9 and now it can be implemented in PS4 and Mid Spec PCs now

*"New: Improved Distance Field Ambient Occlusion

Sky occlusion gives nice soft shadows around objects lit by the sky, especially important in overcast lighting scenarios, a use case traditionally hard to render at high quality without precomputed lighting. Distance Field Ambient Occlusion solves this for fully dynamic games where both the time of day and environment can change at any time. We’ve put a lot of effort into improving the quality and performance of the technology for 4.9 and believe that it is now a shippable feature on medium spec PC and PlayStation 4 level hardware with a total GPU cost of under 4ms for a typical game scene!
The previous method did adaptive sampling, so flat surfaces did less work, but this also caused a lot of splotchiness in clean environments.
The AO computations are now fast enough to get rid of the adaptive sampling, so occlusion is much smoother.

The catch is that the new method requires a longer history filter, which can contribute to ghosting, especially when shadow casters are moved. Hopefully this can be improved in the future.
Performance
Distance Field AO has been made much faster such that it can run on medium spec PC and PS4. It also has a much more reliable cost now, so that it’s mostly constant, with a slight dependency on object density.
In cases with a static camera and mostly flat surfaces, the new method is 1.6x faster. In complex scenes with foliage and a fast moving camera, the new method is 5.5x faster. The cost of Distance Field AO on PS4 for a full game scene is 3.7ms.
Technical details
The main optimization is the use of a global distance field, which follows the camera around. This is created by compositing all the usual per-object distance fields into a few volume textures centered around the camera, called clipmaps. Only newly visible areas or those affected by a scene modification need to be updated, so the composition doesn’t cost much.
Visualization of the texel size of the clipmaps - each clipmap is a different color

The global distance field is lower resolution than the object distance fields, so it can’t be used for everything. When computing cone traces for sky occlusion, the object distance fields are sampled near the point being shaded, while the much faster global distance field is sampled further away.
This is a visualization of ray tracing the global distance field vs object distance fields. Surfaces in the global distance field have become blobby and thin objects disappear."*
the thread : Unreal Engine 4.9 Released! - Announcements and Releases - Unreal Engine Forums!

but if he can afford using DFAO i recommend it ,getting few ms is always good :slight_smile:

have a nice day

Yes I really need DFAO but the thing is I have the hardware to run it and I don’t understand because on the 4.8.3 all work well is just on the 4.9…

Soo I don’t understand where it can be caused? Is my W10 or DX12 ?
Any ideas ?

Oh I see… 4.9.0 is still new so maybe there is an issue with DFAO performance on 4.9.0 compared to 4.8.3.

The 4.9.0 Editor will default to DX11 if you do not add any flags.

The 4.9.0 Editor will use DX12 with the -D3D12 flag.

Could you use 4.8.3. for the time being? 4.8.3. on Windows 10 is DX11 and is (in general) fine for me.

4.9.0 DX12 causes some issues for me eg. Ray Traced Distance Shadows. But 4.9.0 Lightmapping is much faster.

Anyway, you could post feedback in the relevant section regarding DFAO performance in 4.9.0 DX11/DX12

That’s all I can think of for now.

Ok thank you I will whait for 4.9.1 and still work on 4.8 !

:mad:

thank you for your time !!! :slight_smile:

4.9.1 change nothing I still get this problem !!! :frowning: I see that I got this problem only when I introduce a gemometrie in the scene…

Did you try r.DistanceFieldAO 0 ? That’s in case you don’t need DFAO on, but can help you isolate the problem. Other suggestion - try setting DFAO build scale to 0 for objects that definitely don’t need it. I get a boost of like 4-6 fps when I shut down DFAO in 4.8, but not such a drastic drop as you do. Something else might be at work here. Try setting up a fresh project, copy all your stuff there and see if that helps (could be some weird cvar you set somewhere in config and forgot about).