Download

Looong battle to get Ambient Occlusion ( DESPERTION POST;-)

Hello again,
It seems like every step I want to go with Unreal is in fact Unreal:-). So the problem is We have in Unreal world settings object settings and post production settings… and I tick Ambient Occlusion basically everywhere I could. Now I am trying to bake it and…nothing no ambient occlusion at all… I am not an expert with game engines but in Unity is just a matter of 1 ( yep ONLY ONE) TICK to turn ao ON. I spend nearly entire day trying to bake AO in Unreal …Does any one know where this magic happened???

PS: I did increased light map resolution already.

Enabling Use Ambient Occlusion in World Settings > Lightmass Settings should bake AO, though the looks may vary depending on the scale of your meshes and AO parameters you use. Post some screenshots if you have done this already please.

04d11fa52678c2fd570737171c371826b07f1d05.jpeg
cc24ba3c3cc0991a5c19417eeecca3c07161260f.jpeg
There is Ambient Occlusion turned on, but it doesn’t give effect. Scale is set up to match with first person controller.

Definitely uncheck Visualize Material Diffuse, as this is going to replace your shadows with the materials that Lightmass “sees”. This is a troubleshooting option for some things, but you don’t want that on. I would also reset your “…Occlusion Fraction” settings, since you are reducing the power of the AO on those types of lighting. If you are really wanting to visualize it, you should keep it at default or bump it up.

I don’t know if it will affect the AO directly, as it is a different process, but I would lower your Indirect Lighting Smoothness if you want crisp contact shadows. You can put it at .7 or even lower if you increase your indirect quality.

Edit: And please make sure you are using a static or stationary light source, as Movable is not computed by Lightmass. I will bet $0.50 this is the problem.