LogStats:Warning: MetaData mismatch

LogStats:Warning: MetaData mismatch. Did you assign a stat to two groups? New //STATGROUP_Threads//FGenerationWorker///Thread_68c_0///////STATCAT_Advanced//// old //STATGROUP_Threads//FGenerationWorker///Thread_ce4_0///////STATCAT_Advanced////

Can you tell me please what is this about. And how can i get rid of these warnings messages?

I’m getting the same error. stuck on main menu. :frowning:

The threads or objects has the same name. That’s all.

@Azarus, what do you mean, and how to do you change it?

I’m having the same error in my Output Log for Launch. I’ll build my scene with production lighting, but that build only works in Play Preview. In Editor Launch and .exe Launch it reverts to a previous light build at runtime then converts my scene back to that light build upon exit. Is it just a 4.7.2 issue?

I got this error because i had multiple threads running with the same name. It shouldn’t cause any problems thought.

According to the documentation the second parameter should be unique for each thread instance.

FRunnableThread::Create(RunnableObject, TEXT("UniqueThreadName"));

After giving an unique name for each thread i spawn the error dissapeared.

So many people looking for proper answer, so i update my answer.

This error happens when you have two or more threads, objects with the same name.

In my case i spawned multiple threads with the same name. To handle multiple tasks. (That was actually bad in general and pointless to spawn more than one thread in my case).

To generate an unique thread name for each task you want to perform you can use the
“FThreadSafeCounter” object

// Create a counter
FThreadSafeCounter  WorkerCounter;

// Increment the counter and create an unique name.
FString ThreadName(FString::Printf(TEXT("MyThreadName%i"), WorkerCounter.Increment()));

// Create the actual thread
FRunnableThread::Create(RunnableObject, *ThreadName);

could you please tell me how exactly did you solve this?

I generated a different name for each thread.

how?! :c. Please help!

Not meant to sound rude or anything…but what can be something obvious to you may be a complete blank for somebody else. I’m having the same issue for weeks now and whilling to find an answer. So please, if you guys could give a detailed solution to that it would be awesome.

Please T-T I’m really struggling because of this while launching to Android.

You have to give an Unique name to your objects.

i’m getting the same error. and i’m not ever starting any threads in code so i’m not sure what this renaming would be or where it would occur. i’m following the readme, it says to launch the html5launcher to start the server. then i open the main web page titled mygame.html. it never opens due to this error

unique name to which objects?

which threads and where? i never start any in code or control any naming that i know of

I get this error too while launching a completely clean, no content, blank map. The only thing in the level is Fog, Floor, Light Source, Player Start, and Sky Sphere… as assigned by the engine for blank maps.

the same error guys… please help me…
i just opened “Shooter Game” in editor, no change nothink, and just try to launch game… and

LogPlayLevel: Completed Launch On Stage: Build Task, Time: 0.751933
LogStats:Warning: MetaData mismatch. Did you assign a stat to two groups? New //STATGROUP_Threads//FLauncherTask///Thread_3c34_0///####STATCAT_Advanced#### old //STATGROUP_Threads//FLauncherTask///Thread_420c_0///####STATCAT_Advanced####
LogPlayLevel: Completed Launch On Stage: Build Task, Time: 0.000045
PackagingResults:Error: Error Launch failed! Unknown Error

What i do?
i read all post… but really dont understand…

hi there, i am experiencing this issue, would you kindly be able to provide step by step instructions please?
It will help a lot of users out here.

Could you expand on your answer please? We don’t know how to give a different name to threads. And google didn’t help me much. Thank you. :slight_smile:

It’s in my answer TEXT(“Threadname?”)

FRunnableThread::Create(WorkerObject, TEXT("ThreadName Replace this string with an unique name")

and where do we edit that thread name please?

I use 4.11.2ver and every my 11ver project all happen same error.
but strangely I can package them and they can run rightly.
but still I can’t launch in editer