Download

LODs getting imported in wrong angle

Greetings,

For now importing of LODs was working fine but suddenly my LODs are getting imported in Y direction (-90) degrees. I am using 3ds max and applied reset xform several times but no luck so far and also double checked that my all mesh pivots are at same place. So far I tried to figure it out but no idea what exactly is going on.

Regards,

Jalay

Hi Jalay,

There was a bug with this that I reported not too long ago (UE-5041), but from my testing I was only able to get it to do so with a model from Maya.

If I can a repro for this with Max I can update that original bug report.

What version of 3Ds Max are you currently using? I’ve only tested and have access to Max 2013.

Can you walk through your steps to get the -90 rotation to happen every time? Be as detailed and concise as possible. The quicker I can repro on my end I can update the bug report.

Thank You!

Tim

This is really weird. I had this happen a few times as well. I am not able to reproduce it though. What I did when this occured the last time:

I created a mesh in Blender, exported it (Using the same preset I always use for fbx), imported it to UE4 as LOD.

Now it was rotated 90 degrees, so because I didn’t find a fix for it (Tried importing it several times), I went back to Blender, rotated it the in the opposite direction as a temporary solution, exported again, imported again and it was fine.

Then later, (I did NOT export the mesh again from Blender, it was the same file), I imported it again (As LOD for the same object), and for some reason it was imported the correct way (Note: Correct = The same as in Blender, which in this scenario was rotated 90 degrees).

Thanks HammelGammel for adding some information. I’ve not run into it in that sense either. Good info none-the-less. With the Maya bug I submitted this was a 100% every time repro.

If you’re able to get a consistent repro feel free to post here and I’ll test on my end and update the bug accordingly. I’ll continue to look into this on my end as well since others appear to have the issue outside of Maya.

Thank you!

Tim

Greetings Tim,

I am using 3ds max 2015, I am writing down the steps that I use to import LODs.

  • Reduced down the polycount from base mesh.
  • Aligned my mesh and pivot to the base mesh (0,0,0).
  • Applied Reset Xform.
  • Exported out mesh (fbx version : 2014).
  • Clicked on my base mesh and clicked import Lod option.
  • Mesh roatates in 90 degrees (Y angle) (Note : Mesh rotates 90 degrees or -90 in Y direction, cannot see the angle number in editor).

I hope this information hels you for the bug report. If you need more information I am up for it. It was hell of a day for me because I had never encountered this bug before.

Regards,

Jalay

Hi Jalay,

I’ve spent some time this morning trying to reproduce this on my end using different methods and have still not been able to get the same results. It is likely that since I only have access to 3Ds Max 2013 on my machine that there could be an issue with Max 2015 and the fbx process that is happening.

When I reported the issue I could get the same results with Maya 2014. I do have access to Max 2014 and 2015 on my machine at home. I will give this a quick test this weekend and see if I see the same results. When I did the test with Maya it did it the first time out so it should be the same with Max if 2014/15 has an issue with the export. Regardless I will add your notes to the bug that is already reported.

I’ll let you know what I find when I test at home. :slight_smile:

Thank you!

Tim

Hey Tim,

Found out temporary solution for the lods, I changed the pivot angle to Y up 90 degrees (default is Z up) and then imported LODs back and worked fine. I Hope in next update or sooner or later this problem might get fixed.

Regards,

Jalay

I have same problem when importing meshes from blender, my solution is to reimport base LOD0 right before importing next lod levels

I had the same pb, the only way i found to fix this is that everytime you import a mesh in unreal, be sure you check the LOD option, even if you don’t have any. Like this, if you want to import an LOD, it will already be LODready and won’t have that pb

I have found a simple workaround for this without paying for max or any other software.

If you have visual studio community edition installed, simply double clicking an FBX can load it into visual studio 2013. Click the mesh’s verticies, and in the toolbox, expand “rotation” and set the X to “90”. Save the mesh, and reimport into UE4.

It’s a faff, but it works without having to pay for extra software and without needing to load up something as heavyweight as blender which you might not already be running…

Let me know if this helps.

I had the same issue. I was referring to the same model i was using for the LOD0 as LOD1 though as I was just running through the paces of creating LODs that I would just try to use the same model on, and then refer to Materials with lower resolution textures I had made. I tried reading other models in to replace it, but it always was rotated at 90 degrees and offset down some distance.

So I went back to my modeler, I generated a reduced resolution version of my original model, and a lower res and exported them appropriately. Then I re-imported my LOD1 and LOD2 using those models.

Everything snapped back into place with my models that were freshly exported. I don’t know if i’ll run into this again, but I’ll probably not try to cheat the system again.

Hi Tim. It’s a year and a half later, on 4.10.1, and this issue persists in Maya when reimporting LODs. Could you please revive this bug?

Just to clarify, the bug currently is: Import an LOD, it comes in at 90 degrees. Reimport the LOD, and it comes in fine. So perhaps the bug was half fixed.

Also happening here for myself and several other artists in the studio. It’s a massive problem that seems to be getting ignored.

Max 2014 using FBX Plug-in version: 2014.0.1

Its 2020 corona time, and this is still not fixed. I have LOD0,1,2 LOD0,1 are fine but LOD2 that is plane with mask that represent fence is always moved in side, whatever I do, reset x form copied polygons everything, still when I import whole scene from 3ds max (big house with instances) it happens. When I export just fence, and import in UE it is fine… but it is difficult to put in place now any help with this?

Yes, it still happening. The solution: rotate 90 degres before send to UE.:cool: