Loading Package hangs during insert of static mesh to scene

When i attempt to insert the static mesh “HillTree_02” from the free kiteDemo content package my loading sequence hangs at 72% for around 1/2 hour before the item loads.
This was the 2nd time I attempted to load this item and the first time i sucessfully loaded the item (the first time i used task manager to abort the process by killing unreal engine after about 15 minutes of hang)

Is there a means to improve loading times?

A detailed description follows:

Specifically I am inserting the package Content->KiteDemo->Environments->Trees->HillTree_02.
This is from a vanilla version of the downloaded content package; the tree has not been modified in any way.
The insert command sequence is: navigate through the content browser to select the “HillTree_02” object mesh; then right click in the primary scene window where i wish it inserted, which opens a dialogue from which i select the tree object. Next the Loading Package dialogue pops up already at 72%. It then proceeds to hang running probably around 25% of the cpu for the next 27+ minutes. At the end the tree pops up where it should be.

My machine is a msi built labtop GE60

CPU intel core i5-3230M

VGA Nvidia GeForce GTX 660M / 2GB GDDR5


The operating system is Windows 8.1

After the tree has been loaded my with the Unreal Editor open to my scene Task Manager shows the following stats:
Epic Games Launcher is listed as using about 25% of the CPU and 507.0MB of memory.
Unreal Engine is listed as using around 1.4% of the CPU with 522.6 MB of memory.
The overall memory usage on the machine is listed at 50%

I was running Chrome browser and Windows explorer in the background.

Update: After the first tree loaded i tried adding more instances of the same HillTree_02 object; These went in without issue or significant delay. I also tried adding another tree from the same package, the small pine. There was a delay of at least a few minutes in loading this mesh; however no where near the 1/2 hour experienced before. (btw this font is not my idea, the forum software does not wan’t to use the normal one)

Thanks in advance :slight_smile:


Hi blackbird658,

The reason it opens so quickly from the KiteDemo project, but not when you migrate it out of KiteDemo is because of the Derived Data Cache(DDC) that is downloaded with KiteDemo.

It’s a big part of the reason KiteDemo is so HUGE. The DDC holds the compressed versions of all the textures and other assets. So when you migrated the asset out of KiteDemo and loaded it, it has to re-compress everything associated with HillTree_02. That includes a good number of 4K and 2K textures.

I’d check out our documentation on DDC for more info. If you migrate a bunch of assets over to your project (or ones that require a great deal of compression), I’d suggest at least setting up a local DDC and building it. That way you can walk away for a while as it compresses everything, then come back with it ready to go.


As an added note, I wouldn’t necessarily look to KiteDemo for assets to use in your own game projects(especially anything geared for consoles or mobile). Those assets are balanced more towards visual quality than running smoothly, which is why the system requirements for the demo are so high.

Having this exact same issue in 2018 with 32 cores, 64GB RAM, GTX 1080 Ti.