Loading at runtime Skeletal mesh and Animation imported from PAK

I tried to load at runtime a skeletal mesh from a PAK (mounted with c++), using set Skeletal Mesh.
It load the mesh but when i try to play the Animation (also loaded from the pak) it fails.

The output log return the error:

LogAnimation: Warning: SkeletalMesh skeletal_mesh_1 has no skeleton. This needs to fixed before an animation can be set
LogBlueprintUserMessages: [UnpackBP_2] Skeletal Setted
LogSlate: Took 0.000187 seconds to synchronously load lazily loaded font '../../../Engine/Content/Slate/Fonts/DroidSansMono.ttf' (77K)
LogAnimation: Warning: Animation persiana1_armatura_Anim is incompatible with skeleton persiana2_armatura_Skeleton, removing animation from actor.

I tried many combination of play animation, override animimation data, set animation etc etc
The set Skeletal Mesh and play Animation works when I use the static assets in the project, but fails when loaded from the PAK.

Is there any right way to load and use the Skeletal mesh and all its component from the pak?


hey. I really want to know how you load skeletal mesh and anim runtime .