Load UAnimBlueprint crash in Android device

I used LoadAnimBPFromPath to load my AnimBlueprint, but it work well in pc and Mobile preview,
but it crashed in Android device, who can help me, thanks,

template
ObjClass* LoadObjFromPathPTR(const FString& Path)
{
return Cast(StaticLoadObject(ObjClass::StaticClass(), NULL, *Path));
}

static FORCEINLINE UAnimBlueprint* LoadAnimBPFromPath(const FString& Path)
{
return LoadObjFromPathPTR(Path);
}

Howdy Alex,

Thank you for porting this issue. I am going to need a bit more information from you before i begin digging into this issue. What version of UE4 are you currently using and is that version a binary build or a source build of the engine? Also, would there be an quick way that i may be able to repro this issue internally?

Any additional information would be greatly appreciated.

Thanks and have a great day!

It crash in m_Mesh->SetAnimInstanceClass(m_pAnimBlueprint->GetAnimBlueprintGeneratedClass()) on Android device,
cloud you help me to fix it or tell me how to debug it…,

I used Unreal engine 4.6 (version a binary build),

Hey Alex,

Thank you for the additional information. Would you be able to include the build logs from your project when you package? Also, Are you able to see any Android logs when the game crashes? If so, could you also include those.

Also, would you be able to provide a bit more context on how I may be able to reproduce this issue? I am a bit lost on the line that you have provided for setup. Would you be able to recreate this issue form a template project?

Thanks!

Thanks very nuch,

I don’t know how to get debug info or debug my code from Android device,
I have created one simple code to play character animation by using SetAnimInstanceClass,

Clound you help me, I have speed more than on week on this problem,
Our game ready to publish next month, Please help us,
Thanks.

download: 百度网盘-链接不存在

Thanks very much, I solved,

bDontLoadBlueprintOutsideEditor= false

Howdy Alex,

Glad to hear that the issue has been resolved. Please feel free to reopen this issue in the future if you come across the same error.

Thanks and have a great day!