Download

Load level with world partition from blueprint crash

Load level with
image
or from level name every time crash

I am having the same problem. I have yet to work out how to not crash.

Doing the following has allowed me to load a level that has world partition.

Unload level dont help :frowning:

LoginId:4d187d254761904f6ba2b6afbb0160cc
EpicAccountId:3c0d6d7841ca4d6d8cf0ae00c48c648a

Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0x0000000000000000

UnrealEditor_Engine!FWorldPartitionLevelHelper::RemapLevelSoftObjectPaths'::2’::FSoftPathFixupSerializer::operator<<() [D:\build++UE5\Sync\Engine\Source\Runtime\Engine\Private\WorldPartition\WorldPartitionLevelHelper.cpp:122]
UnrealEditor_CoreUObject!FArchiveUObjectFromStructuredArchiveImpl::operator<<() [D:\build++UE5\Sync\Engine\Source\Runtime\CoreUObject\Private\Serialization\ArchiveUObjectFromStructuredArchive.cpp:119]
UnrealEditor_CoreUObject!FSoftObjectPath::Serialize() [D:\build++UE5\Sync\Engine\Source\Runtime\CoreUObject\Private\UObject\SoftObjectPath.cpp:236]
UnrealEditor_CoreUObject!UScriptStruct::SerializeItem() [D:\build++UE5\Sync\Engine\Source\Runtime\CoreUObject\Private\UObject\Class.cpp:2746]
UnrealEditor_CoreUObject!FStructProperty::SerializeItem() [D:\build++UE5\Sync\Engine\Source\Runtime\CoreUObject\Private\UObject\PropertyStruct.cpp:152]
UnrealEditor_CoreUObject!FPropertyTag::SerializeTaggedProperty() [D:\build++UE5\Sync\Engine\Source\Runtime\CoreUObject\Private\UObject\PropertyTag.cpp:241]
UnrealEditor_CoreUObject!UStruct::SerializeVersionedTaggedProperties() [D:\build++UE5\Sync\Engine\Source\Runtime\CoreUObject\Private\UObject\Class.cpp:1589]
UnrealEditor_CoreUObject!UStruct::SerializeTaggedProperties() [D:\build++UE5\Sync\Engine\Source\Runtime\CoreUObject\Private\UObject\Class.cpp:1287]
UnrealEditor_CoreUObject!UObject::SerializeScriptProperties() [D:\build++UE5\Sync\Engine\Source\Runtime\CoreUObject\Private\UObject\Obj.cpp:1468]
UnrealEditor_CoreUObject!UObject::Serialize() [D:\build++UE5\Sync\Engine\Source\Runtime\CoreUObject\Private\UObject\Obj.cpp:1388]
UnrealEditor_CoreUObject!UObject::Serialize() [D:\build++UE5\Sync\Engine\Source\Runtime\CoreUObject\Private\UObject\Obj.cpp:1273]
UnrealEditor_Engine!FWorldPartitionLevelHelper::RemapLevelSoftObjectPaths() [D:\build++UE5\Sync\Engine\Source\Runtime\Engine\Private\WorldPartition\WorldPartitionLevelHelper.cpp:133]
UnrealEditor_Engine!UWorldPartition::Initialize() [D:\build++UE5\Sync\Engine\Source\Runtime\Engine\Private\WorldPartition\WorldPartition.cpp:444]
UnrealEditor_Engine!UWorldPartitionSubsystem::PostInitialize() [D:\build++UE5\Sync\Engine\Source\Runtime\Engine\Private\WorldPartition\WorldPartitionSubsystem.cpp:77]
UnrealEditor_Engine!UWorld::PostInitializeSubsystems() [D:\build++UE5\Sync\Engine\Source\Runtime\Engine\Private\World.cpp:8148]
UnrealEditor_Engine!UWorld::InitWorld() [D:\build++UE5\Sync\Engine\Source\Runtime\Engine\Private\World.cpp:1763]
UnrealEditor_Engine!UEngine::LoadMap() [D:\build++UE5\Sync\Engine\Source\Runtime\Engine\Private\UnrealEngine.cpp:13190]
UnrealEditor_Engine!UEngine::Browse() [D:\build++UE5\Sync\Engine\Source\Runtime\Engine\Private\UnrealEngine.cpp:12502]
UnrealEditor_Engine!UEngine::TickWorldTravel() [D:\build++UE5\Sync\Engine\Source\Runtime\Engine\Private\UnrealEngine.cpp:12700]
UnrealEditor_UnrealEd!UEditorEngine::Tick() [D:\build++UE5\Sync\Engine\Source\Editor\UnrealEd\Private\EditorEngine.cpp:1700]
UnrealEditor_UnrealEd!UUnrealEdEngine::Tick() [D:\build++UE5\Sync\Engine\Source\Editor\UnrealEd\Private\UnrealEdEngine.cpp:450]
UnrealEditor!FEngineLoop::Tick() [D:\build++UE5\Sync\Engine\Source\Runtime\Launch\Private\LaunchEngineLoop.cpp:5032]
UnrealEditor!GuardedMain() [D:\build++UE5\Sync\Engine\Source\Runtime\Launch\Private\Launch.cpp:171]
UnrealEditor!GuardedMainWrapper() [D:\build++UE5\Sync\Engine\Source\Runtime\Launch\Private\Windows\LaunchWindows.cpp:137]
UnrealEditor!WinMain() [D:\build++UE5\Sync\Engine\Source\Runtime\Launch\Private\Windows\LaunchWindows.cpp:268]
UnrealEditor!__scrt_common_main_seh() [d:\agent_work\5\s\src\vctools\crt\vcstartup\src\startup\exe_common.inl:288]
kernel32
ntdll

Unloading only seemed to work for me a few times. I tried the Ancient Demo and that give same crash too.

I have this same issue, Found a Work around, Use the Open Level by Name instead of by Object Reference. Should work, worked for me :slight_smile:

Open by name crash too

If you open your menu imeediately in Editor, then try to open level by any means via your interface BP it will cause a crash. I assumed the same by different methods and it worked but the level was already loaded somewhere. On a clean load of UE5 then trying anythin in Menu BP to load it resulted in a Crash.

Okay it worked for a bit using the Name version but then suddenly it started doing the same crash.

Just wanted to chime in to say that I’m getting the same error with a read access violation 0x000

Also getting that same error

Has anyone tried compiling source and attach debugger?

Crash is happening in this line of code:

void UWorldPartition::RemapSoftObjectPath(FSoftObjectPath& ObjectPath)
{
	StreamingPolicy->RemapSoftObjectPath(ObjectPath);
}

this function is in WorldPartition.cpp.

If i go inside RemapSoftObjectPath Function , it shows like this.

#if WITH_EDITOR
	virtual TSubclassOf<class UWorldPartitionRuntimeCell> GetRuntimeCellClass() const PURE_VIRTUAL(UWorldPartitionStreamingPolicy::GetRuntimeCellClass, return UWorldPartitionRuntimeCell::StaticClass(); );

	// PIE/Game methods
	virtual void PrepareActorToCellRemapping() {}
	virtual void ClearActorToCellRemapping() {}
	virtual void RemapSoftObjectPath(FSoftObjectPath& ObjectPath) {}
#endif

I think this crash only occurs in PIE mode, I will make a build and see if crash happens in build version too and update my reply…

An update to the UE5 build 2, and it is still present at least PIE. I tried packageing and game exits with fatal error.

Same thing, with build 2 and crash…

I had it working before seeing this post, so I did some tests to see if I could make it crash

I did…
what I found from my testing it which I guess will only work on a new project because my project is completely broken now :woozy_face:

  1. New Project
  2. Create a Main Menu Map
  3. set you Main Menu map to Game default in Maps and mods
  4. Enable world partition
  5. Create your InGame Map
  6. Set your InGame Map to Editor default map
  7. restart and click play ( ~~ with my experience with ue5 is that the Main Menu will launch first even though the InGame Map is the one that is open ~~ EDIT: forget this comment I have old code that handles loading the Main Menu)

Alright I did some further tests with some success (kind of, might only work with 1 map with partition on)

my setup was to have 1 map (the main menu) without World Partition switched on and on your main world (In Game Map) have world partition on for this to work you MUST have the map open in the editor view first … you can do some magic in your InGame map to load the main menu if you want that to load first (This is only required in the EDITOR mode)

as for multiple maps I have not tested on how to handle this

I hope the provide a fix for this before they actually fully release UE5

Same crash

Same crash: Interestingly if you go from a world partition level to a level that does not use world partition it does not crash. Only when you go to a world partition level does it crash.