Download

Live Link doesn't connect to Windows 10

I am using the latest version of Live Link (downloaded today) on my iPhone and Unreal 4.25 is running on my Windows 10 machine. The machine has a static IP and I have configured Live Link to point it. No matter what I try though there are no connections shown in the Live Link plugin window in Unreal.

Things I have tried:

  • setting the port number in Live Link specifically to 11111
  • turning off the Windows Firewall for the local network
  • rebooting the machine
  • disabling the plugins, restarting Unreal, reenabling them and restarting Unreal
  • setting the Live Link protocol to 4.24; set this back to 4.25

Any ideas?

Someone else suggested that it was because my machine has multiple network interfaces and that I should set the UDP unipoint address to the static IP of my wifi interface. I did this but it did not fix it, even with restarting Unreal and Live Link.

I figured it out. First, my wireless NIC was mis-classified using the public profile and not the private profile; the latter allows the machine to be seen inside the local network.

Second, I had to open Advanced Settings in Windows Defender and add a new rule that allowed access to port 11111 via UDP from connections using the private network.

I hope this helps someone.

7 Likes

I’m Japanese. Thank you for your tips. Switching to private profile fixed to my problem like your case. I love you.

Thank you for this…

This worked like a charm and hopefully someone from UE4 will add this to the official document.
@Amanda.Schade

1 Like

would you please explain “my wireless NIC was mis-classified using the public profile and not the private profile”
im trying to fix the same issue with no luck

Okay…

You need to change the wireless connection from public to private.

See attached.

That’s in the wireless connection on the tab bar.