Lit Translucent Material...

I’m trying to set up some blending to get rid of hard intersections, as shown in the shot. I’m using a Lit Translucent shader with Surface lighting. My sun light is stationary but with a Dynamic Shadow distance.

So, the problem is with Lit Translucency and shadows. It works fine within the radius of the dynamic shadows, but when I move away and static shadows is supposed to take over, it doesn’t work anymore. The model is lit. So in the screen shot, the right side shows the model is lit when it should be in shadow, using the static shadow as the shadow. On the left side I included to show what it should look like by disabling Affect Translucent Lighting on the sun light.

Question is, how can I make this work?. Since I can’t exclude that mesh alone from the sun and it doesn’t seem to care about static shadows. Is there a way to “light” a static mesh with translucent shader so it blends with other static meshes around it using baked lighting?.

In the UDK there was actually a way to make the translucent shader do this, but none of those options are available and I just wonder if UE4 can do this in another way or just can’t do it yet?.


Stationary lights shadowing translucency was just added, it will be in 4.3. Until then, increase your CSM shadow distance (DynamicShadowDistanceStationaryLight).

Thanks for the reply and for confirming 4.2 does not support the feature. I can certainly wait for the update on that and glad to hear it’s in there.

Thanks again.