Lit material in custom depth

I’m not familiar with custom depth usage, but seams it’s close to what I’m lookin for. I want to render my first person mesh unculled. So i’ve found this material working within PP volume to display culled objects and always draw outline around them. But it uses only Emissive channel (what maeby is correct). How I should change it to have my mesh visualized as a lit model?

im not entirely sure what youre asking, but i think what youre trying to do is click on the big material node on the right, then in the details panel change the lighting mode to lit

As You can see on the top image culled part of the rifle is highlighted, and on the image below I show the part of the material responsable of that highlighting. But instead of that highlighting I need to visualize normally rendered rifle

“LIGHTING NEEDS TO BE REBUILT (17 unbuilt object(s))” This is the issue you may need to fix. At the very top of the window there is a bar that you can do things like close the… (TBC).

no, man, just no. It’s all another question

What do you mean? If you change something in the Blueprints and compile then the lighting needs to be updated because nothing will update the lighting.
where it says build there is an arrow for more options then click on build lighting only. At lest remove “LIGHTING NEEDS TO BE REBUILT (17 unbuilt object(s))” by building lighting only.

Ideally, your capsule would prevent a lot of intersections, and then you could use IK to modify the position of your hands/arms to make the gun not penetrate the wall. However, if you literally want to perform the task of drawing the gun on top all the time, you need to make it a UI Widget using UMG.