Linker error when trying to use SQLiteSupport module

This is mainly a summary of the bug described here:

I am trying to use the third party SQLiteSupport module included with the Unreal Engine. This requires downloading and compiling the sqlite source itself, which I did. I then added the line PublicDependencyModuleNames.Add(“SQLiteSupport”); to my file. Attempting to compile this causes a bug which can be worked around in a few ways (see the linked forum post), but it also throws a linker error even when the compiling problems are worked around.

The error is:

LINK : fatal error LNK1181: cannot open input file ‘C:\Program Files\Epic Games\4.7\Engine\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-SQLiteSupport.lib’

I confirmed that this lib file does not exist, but now I am confused. Where should it have come from? When is it supposed to be created, and what did I miss? A lib file was created when I compiled the sqlite source code, but it has a different name and file path, specifically:

C:\Program Files\Epic Games\4.7\Engine\Source\ThirdParty\sqlite\lib\x64\Release\sqlite.lib

At this point, I don’t know what I have to do to enable use of sqlite.

This is currently being addressed in the bug report section, so I am closing this question.

Link to the bug report: