Line Trace causing very odd issue

I’m really hoping someone can help me out here. I’m making a simple app for the GearVR to show off tomorrow. I’ve got the line trace working well (blueprints), text displays as intended when I gaze at an object. So with it tested, I decided I’d hide the red line/block by switching ‘DrawDebug Type’ to ‘None’. Now when my app loads, it’s completely black. If I scan around and manage to look at an object that responds to the line trace, everything appears. Then, if I look away quickly, everything goes dark (this time, not totally dark - I can still faintly make out objects), however, when I look away from it slowly, it all looks fine.

I’ve tried several things, only turning this to ‘none’ and ‘one per frame’ and it’s constant that none causes issues, once per frame is fine. I’ve restarted Unreal and my Note 4 to no avail.8c8943918aadc8fa8986cd5ebfb8aa1718173311.jpeg

On the PC it works fine, just when I package it and put it on the GearVR does it go crazy. Any suggestions? I’d really be grateful for the advice.

Edit: I don’t know if this helps, but in developer mode on my phone, if I type ‘Stat FPS’ into the console, suddenly I can see everything.

Further to this, I’ve just spent over 2 hours making minor alterations to see if I can find the problem. I thought I solved it, it seems to be when I create an actor with an interface class attached, it causes the screen to go weird. I created a new actor and attached the interface class and made a cube appear when I looked at it. All was working fine. Now, I deleted a few random cubes I had placed around (nothing to do with any blueprints) and all my work is undone again and I’m back to square one. I’ve got no idea how to solve this, and only 1 day left to figure it out. Any ideas? Is something wrong with my trace?



chirsedhog, I can’t help you, but did you post this on AnswerHub as a bug, too? It’s more likely to be viewed by an Epic employee there.

Hi Btengelh, thanks for your suggestion. I have actually posted a couple of questions there however none received answers. I’m sure I’ll figure it out eventually though!

In Vive this is the set up that works for me.

And out the macro into the linetraces

Thanks Motanum, really appreciate your reply. It’s funny, maybe it’s a bug with UE4 and GearVR because now I’m still finding the screen goes odd, one eye will stop rendering some of the textures so in my left eye, some elements will turn all black when I look in certain directions. Perhaps it’s that I have too many textures on screen? But surely 6 basic colour only textures can’t be too many…

That does not sound like something that is related to having to many Textures on screen at one time. It sounds more like you are using mobile HDR, which is not supported with Gear VR. One thing that I have noticed causing some issue similar to your is using UMG. UMG was not designed nor tested for VR so if you do try and use it you will run into things like this, just an FYI.

Thanks for the reply Sam, does this mean I should avoid using Line Trace when creating content for the GearVR? Is there an alternate way to do ‘look to select’? To my knowledge I’m not using anything that is part of UMG, I only have very basic interaction. Look at arrows, tap to move to where they are, and that’s it. I have mobile HDR turned off, and someone else suggested making sure there was no default touch interface set up which I’ve done and I’m still having the same issue. It’s driving me crazy, seem to get rid of it then it comes back the next time I build. Some objects just turn totally black in only the left eye. Any other things I could try?

Thanks very much for your suggestions thus far.

Could also be interesting to know the following to see if anyway has a similar problem:

Hi Aussieburger,

Sounds like a good idea:
Note 4 Chipset: Snapdragon
Android Version: 5.0.1
Unreal Version: 4.8.3
I’ve not seen this demo, I’ll try it out ASAP.

Thanks for responding. Do any of my specs suggest it may be something to do with my setup?