Lightshaft Bloom Different in Game

I recently converted my project from 4.7.6 to 4.8. Since then I noticed that the lightshaft bloom behaves different in PIE.

In the normal editor view the bloom looks right, such I know it from the previous versions.

Hi -

Are you using any VR or are you in VR mode in the editor? If so this is a known issue, for reference UE-17032, and we are investigating a solution now. I will keep you informed as we work toward a solution.

If you are not using any VR or in VR mode, please let me know and specifically what your project setup is?

Thank You -

Eric Ketchum

Thank you Eric for your reply.

I’m not using VR, but I have found the culprit: The resolution scale, if different from 100%, causes this issue. With 100% it looks just fine, but with a lower value the sun shafts turn more and more into a streak.

Hope it helps.

Hi -

I was able to reproduce the issue and have entered a new report, UE-17199.

Thank you for the additional information.

Eric Ketchum

I think I’m experiencing a similar issue. My lightshaft bloom is different when I render my matinee sequence…I’m assuming this is caused by the same issue? Any idea how I can force the resolution scale to be 100% and avoid this problem?

HI cman2k -

The resolution can be set in the Post Process Settings of the camera or in an unbound Post Process Volume.

Eric Ketchum

forcing resolution scale to 100% via the post process settings of my camera did indeed fix my lightshaft issues when capturing via matinee. Thanks!