Download

Lights going through BSP and static mesh walls

I have set up some rooms, with BP Lights, but I noticed that the light bleeds throug the walls it seems like its only visible on the floor. I then converted some walls from BSP to meshes and ticked two sided shadow and two sided light but nothing changed. How can I fix this?

lightbleed.png

If you increase the resolution of the shadow receiver, the problem will be less.
Also, make sure you have a few pixels of margin around each light map area – at least 2 pixels (I think this is the default, but I could be wrong.)
Another option is to put a second shadow blocker a little bit inside the wall, so that the raycast from the edge of the floor actually hits a blocker.

I set lightmap resolution from 64 to 256, I put a second wall mesh inside my wall. Nothing has changed not even a bit. This is really annoying

Edit: I even increased my wall thicknes to unrealisticly thick, and still no change. Set lights to static, using production lighting quality.

Did anyone find a solution to this? I have a similar situation. With stationary lights and a movable mesh.