Lights and shadows problems

I’we been trying for hours to fix problems with lighting and shadowing. No matter what i do, trees in my project always become almost completely black after i build lighting. And i have no idea how to fix that. Trees and bushes look great until i build lighting. Any way to exclude them from lighting build process? Also i have this weird shadow shape in one corner. Shadow should go down in a straight line. But it’s curved. And i get shadows on several steps of stairs. Those stairs are directly lit by sun. There should be no shadow.

A couple of questions:
Are these models that you created, or are they BSP’s? Where did they come from?
Can you post what your light maps look like?
Are you modifying the scale of the models after they are imported?

Do you have a SkyLight Actor in your project?

If you would like, you can create an AnswerHub post for this issue so we can directly help you troubleshoot where the problem is occurring.


Andrew Hurley

Make sure your lightmap resolution is high enough. When they’re too low it gets blobby shadows.

Hey DuxCro,

Take a look at the Wiki Lighting and troubleshooting guide (linked in my signature). This should help you with a lot of basic lighting issues.

As DotCam suggested this just appears to be a low lightmap resolution.

Problem was in skylight mobility setting. Those trees are animated. So i changed skylight mobility from stationary to movable. Looks good now. Still having those shadows on stairs and weird shadow on one wall. Almost all assets are migrated from Sun Temple and Blueprints examples.
I’ll try to troubleshoot it with lighting guide.

Thank you for your help.

If you still have questions feel free to ask. Post any relevant screenshots along with lightmap resolutions being used. I can’t remember for sure if migrated content retains the set on resolution or reverts to default. You can check this in the static meah editor to be sure though.