Lightning build Problem

Hello all!

Im starting to learn UE4 (4.7.4) (Windows 7 64bit)
I was building a basic level. nothing special. Just 4 walls, a window, and Light - Enviroment. Some start up stuff.
When i move the light it sais “preview” in the shadow. And when i am playing there is the message u all know: "LIGHTNING NEED TO BE REBUILD (10 unbuild obect(s))

Ok now i hit Build (or build lightning only). This should work.
But it doesnt. A short window pops up with the title: Build status. And nothing more is happening.
I tryed reinstalling but no changes. After 6hours frustration i guess i need your help

I hope anyone know what i am dooing wrong.

Thanks, Levion

EDIT:
Just checked: Unreal Engine version 4.6.1 Is working and does not have this problem.

EDIT2:
Updating to 4.7.5 does not fix the problem.

EDIT3:
I click on Build and Swarm Agent starts running (nothing happen after this)
When i open Swarm Agend heres what the Log sais:
20:37:29: Starting up SwarmAgent …

20:37:29: … registering SwarmAgent with remoting service

20:37:29: … registering SwarmAgent network channels

20:37:29: … initializing SwarmAgent

20:37:29: … certificate check has failed

20:37:29: … initializing cache

20:37:29: … using cache folder ‘C:/Users/levion/AppData/Local/UnrealEngine/4.7/Saved/Swarm\SwarmCache’

20:37:29: … recreating SwarmAgent cache staging area

20:37:29: … initializing connection to SwarmCoordinator

20:37:29: … using SwarmCoordinator on RENDER-01

20:37:32: … SwarmCoordinator failed to be initialized

20:37:32: … initializing local performance monitoring subsystem

20:37:33: … initialization successful, SwarmAgent now running

20:37:33: [Interface:TryOpenConnection] Local connection established

20:37:33: [Interface:OpenJob] Error: Der angegebene Dienst kann nicht gestartet werden. Er ist deaktiviert oder
nicht mit aktivierten Geräten verbunden. (Ausnahme von HRESULT: 0x80070422)

Need help please…

Hi Levion4Games,

If you build lighting in one of the Template levels like the First Person or Third Person template, do these work correctly for you?

If you try clearing the Swarm Cache does this help?
Swarm Cache located here: C:\Users\ [Computer Name] \AppData\Local\UnrealEngine

You can delete everything in this folder.

Let me know.

Tim

Hello Tim Hobson.
Thank you for your answer. I fond some other guys with the same problem here Swarm error - Platform & Builds - Unreal Engine Forums

When i add or move existing lighning this problem is still there. Yes i tried cleaning up my Swarm Cache. Did not work for me.
At the moment i am using 4.6 because i cant get 4.7 to build.

Do you have any other ideas what i could try?
I could not find any help on the web so far.

Big Thanks!

Does building lighting on 4.7 in a new template project work for you at all?

If that works for you, in your own project can you try creating a new level and building lighting on that and see if that works?

I had a guy that was having a similar issue and found it to be a corrupt mesh that would not allow the lighting to build. Deleting and replacing that mesh worked in his case.