Lightning Build Failed. Swarm Failed to Kick off

I looked around the forums at other posts and could not find the right solution.

This problem happened when update 4.7 came and I created a 4.7 version of the project I was working on (my project used to be in 4.6). Ever since then, I have been getting the same error.

I saw a solution on another post that I should find meshes with duplicate names and change them. However I have a lot of different meshes with the same names, does that mean I have to change the names of all these meshes?

Hi Valachio,

Apologies for the delay in getting to this one.

There are a couple of reasons that Swarm Failed to kick off.

Some of the more common ones are that the firewall or antivirus may be blocking it from starting properly. You can disable these and then try to build lighting to see if that works.

The other is that there may be multiple swarm agents opened in your take bar (next to your computer clock in the bottom right). When swarm agent is initialized there will be a orange and black S icon that appears. Close any your see here and then try to build lighting.

If none of that works, can you try building lighting in a new template project like the first person or third person templates? This can rule out if it’s a project specific problem or swarm agent issue possibly.

Thank you!

Tim

No problem, I’m just glad someone responded haha. I tried both of the methods and neither worked. Yes I can build lighting on other existing/new projects. Someone suggested that duplicate meshes may be the problem on another thread (dev666rej):

link text

I went ahead and renamed all the meshes that had the same names and still had the same error.

Hello again Tim. The problem persists for me, is there any other solution.

I can build lighting on any other level in the project, just not on the main level.

So it’s only this particular map that is causing swarm agent to not build lighting and all other maps build lighting correctly?

If that’s the case, it may just be a corrupted map that needs to be replaced. You can go to File > Export > save a .t3d file > Create a new map > File > Import > and select the .t3d file you just created.

This will place any objects in the scene that were in the other map.

This may be an option to get around the map not building lighting.

Still the same error. Jesus… I think I tried this earlier when I copied all assets on the original map into a different map.

Perhaps there is a specific asset/material in the level that is restricting swarm from kicking off? I already tried an earlier method where I renamed all the assets in my content browser that has the same names.

I’ve heard that this had been an issue before with some (Dev666(?) I think), but I’ve not ever personally encountered this issue with materials or assets that stop the light build.

At this point, would you be willing to share the project or the map that is causing issue and I can try to build on my end and see what’s going on? You can share privately via a PM on the forums if you’re willing.

It’s odd that this is only affecting a single map though and not all of them though.

Yes, I think I mentioned Dev666’s post earlier. I don’t think that he had the same problem as I did though. I finally managed to fix the problem by deleting some assets and putting them back into the level. Odd way of fixing it but it did the trick. Thanks for your time!

Thanks for letting me know.

If you don’t mind answering a couple of other questions for me:

  • How did you find the asset that was causing the issue? Delete, build lights, repeat? Was this the process you used to see if it was a mesh causing the issue?
  • Deleting and re-adding this asset fixed your issue completely or was the asset completely unusable with Swarm Agent?

Thanks!

Tim

Yes I deleted a whole section of the map, built lighting, and it worked. Oddly enough, after I restarted the project without saving in order to recover the section of the map I deleted, I built the lighting again without deleting any meshes and it built just fine.

So apparently there was no corrupt mesh that was preventing lighting from building. Just an error with a mesh on the map, which fixed itself after temporarily deleting it.

interesting. This is something I’ve never encountered myself.

Let me know if it comes back and causes any other issues.

Thanks for getting back to me. :slight_smile:

Hey guys! I had this error message and found out the error message was because my C: drive had only 100MB of memory left!

Swarm will also not work with with source code version of the engine, so if you pulled the source from git and compiled the engine you will either need to use your own solution, or bake the lighting in the launcher engine and then somehow import it over.

What worked for me was deleting the data cache:
C:\Users######l\AppData\Local\UnrealEngine\Common\DerivedDataCache

I had this problem as well and would like to add something:

I imported a few static meshes that for some reason didn’t automatically add their materials, one mesh had two Material Elements but I left one of them empty since it didn’t appear to do anything.
And that was what caused the problem, as soon as I added a material to the second Material Element for the Static mesh then light built just fine.

I hope this helps someone!

Hey guys, I tried loads of these solutions. Replacing meshes and materials that had duplicate names. Checking hard drive space. Disabling firewall and anti virus software…

In the end I was trying deleting assets one by one and while checking to see if I could do a light build. I eventually found one that SEEMED to be causing the error. But once I reloaded the original level (without making ANY changes or deleting anything)… it worked fine. I’m no closer to understanding why the swarm was failing to kick off, but it seems like if you screw around with your level enough it just decides to work :-/

I I had this problem as well and would like to say my solution was some POINT LIGHT delete…some of them i delete and build lightning with no problem :wink:

My solution on that problem was deleting some Point Lights…And problem solved for me :wink:

At this point last year I didn’t have this Wiki setup yet, but it may be useful for troubleshooting most Swarm Agent issues:

In my case, it was because a Sphere Reflection Capture was referenced in the level BP !!!