Lightning Build Failed. Swarm Failed to Kick off

4.11.2

Have the same problem. For all projects, even for new projects. Cannot rebuild lights because of this error.

so are u saying that code compiled engine is totally useless?

SOLVED:

  1. Open UE4.sln
  2. Build UnrealLightmass

SOLVED:

  1. Open UE4.sln

  2. Build UnrealLightmass

So far deleting the data cache hasn’t worked for me. This one level I have has done this twice to me now. Very Annoying. What I did to fix it reasonably quickly was use Shift + click to drag and select half the assets in my level using the Outliner list and copy them and then delete them (without saving of course). Then rebuild the lightmass. If it builds you know its an object in the deleted half of the level. Press Ctrl V to paste the half back. Then copy and delete half of the half you first deleted to continue to narrow it down by process of elimination. Hopefully I an easier process can be found soon.

This worked for me! thank you very much!

It’s not. newbprofi said it in a comment - as long as you build UnrealLightmass from your UE4.sln it’s gonna work. Had the same problem but that fixed it.

This has also worked for me, thanks!

This is what fixed it for me.
More specifically, I used the following steps:

  1. Delete the first 20% of assets
  2. Try and start a build.
  3. If Swarm doesn’t kick off, delete another 20% of assets.
  4. If Swarm successfully starts, then cancel and shut down UE4 without saving anything.
  5. re-open the project, and build. Swarm should work.

This was a huge help, I was checking every ■■■■ asset in a 40+ gig project, if you have this problem, definitely do that ^ works…

If you’re on a Mac build the UnrealLightmass target in the Xcode project

This worked for me. I was starting to get annoyed.

Swarm Agent has a log which spits out an error when you get the “failed to kick off” message in the Editor.

The error is that a file in the Swarm cache being used by another process. Leaving procmon running while starting the build, this is the complete list of processes accessing the file in question:

As you can see, only UE4 itself is accessing the file, not even Windows Defender is causing trouble. Could it be that two threads are trying to create the same file, colliding with each other and keeping Swarm from kicking off?

Sometimes I managed to fix the error by just deleting everything, quitting without saving, and reloading, but not always. The error is very random, and often after hours of trying to track down the object in question using the methods above, it turns out to be an object that baked just fine before.

Wish i could upvote this, this saved me a big headache. Did not want to go through all my assets to see what could be the problem.

this solution worked for me with ue4 4.15 source

It seems to be the easiest way, anyway it worked :slight_smile: Thank you!

Wheres that sln file tho?

If you are using a custom engine build, it will be in your engine install folder.

If you have built UE from source code, you will need to manually copy a DLL file or two. If I remember right its the embree.dll and tbb.dll files. You will have to copy them to your compiled UE location \Engine\Binaries\Win64

I just copy them from my UT Editor (launcher installed) location to my development location and this will all ways fix it.

So… what if we dont have ue4.sln? I did a search of every file on my PC relating to UE and have not found it, manually or through the search function.