Download

Lightmass weird pattern

Hello,

I am experiencing weird problem with Lightmass after building lighting. The model is imported from Revit, it’s static geometry (one component with actors) with secund UV generated in 3ds Max with SteamRoller plugin. I am following workflow I had for a long time with everything working fine. Now something happened and after building lighting every single lightmap seem to tile the way it shouldn’t. It also happens when building with Swarm Agent on multiple machines, regardless of lighmass quality settings.

Prvious Revit models were working fine, maybe it has something to do with the fact it got bigger since last time.

Did anybody experience something like this?

053c5c82cc7a3496af38847b47a43f49c29cf4e9.jpeg5f82fef29b973f7927d3318092bc131045b203bf.jpeg

What is lightmap coordinate index set to? It should be set to 1. If that doesn’t fix it, try deleting swarm cache from within the swarm window.

Thanks Ryan, that’s right! It was set to 0. :slight_smile:

Do you have any idea how I can change that value for 6000+ actors inside my component?

You mean 6000 unique static mesh assets? Sadly you’d have to change it on all of them as I am not aware of any way to do them all at once. Actors are containers for static mesh components placed in the world and they shouldn’t have a lightmapcoordinate index, it should be set on the asset in the content browser.

I thought though when you imported a mesh and it generated lightmaps that it set UV1 as the lightmap index by default. what version are you in?

Sorry I named it wrong, I have one actor with 6000 components. That’s an imported FBX file from 3ds max which comes from Revit. I unchecked generate Lightmaps upon import, as I made UV Channel 1 inside 3ds max.

I’m on newly released 4.14.0. It makes me think there might be a bug when importing on this version.