Download

Lightmass 'light source angle' not working?

This works pretty well on UE3, but not on UE4? Has anyone been able to change the ‘Lightmass’->‘Light Source Angle’ parameter on their main light and see the expected results? (Changing the “softness” of the shadows).

Tried on two different maps with no result.

I have also found that it doesn’t work on the light itself, but you can change it in… Project Settings → Rendering → Lighting

Are you using static or stationary lights? Source angle (currently) only works with static lights.

The setting inside Project Settings that I mentioned, will work for Stationary Lights.

Thanks Obihb. I’ll try to test it later today when I’m back at my desk. (I’m using a Stationary light BTW).

Just confirming, the per-light LightSourceAngle only works on Static directional lights (they use proper ray traced area shadows in Lightmass), while the per-project DistanceFieldPenumbraSize controls the softness of Stationary directional light shadows (they use distance field shadowmaps which only support a uniform penumbra size). Sorry for the confusion.

Thanks Obihb and DanielW! Tested the parameter in project settings and it worked perfectly.

I believe i’m having the same issue. i’m trying to adjust the light source angle of my stationary directional light. However every time I change its setting all the shadows vanish?

You need to use 4.9 Preview in order to have area shadows option for stationary dir. lights.

Static lighting gets invalided when you change a parameter that affects it, sometimes it can be annoying.

As of 4.9 the behavior is a bit different for stationary lights: the per-light LightSourceAngle controls how soft the shadows are (project setting DistanceFieldPenumbraSize is gone). You can also use area shadows on stationary lights now, by checking the box ‘Use Area Shadows For Stationary Lights’. The default is still uniform penumbras as they look better under low resolution lightmaps.