Download

Lightmass Help - Photon Issues, maybe

I’m working through getting ArchViz lightmap bake results.
Been combing through the various posts by koola, rafaeris, luoshang etc.

I’ve been getting these results - images below
UE4 renders below are using Directional Light, I get the same results with Skylight minus the clearer beam of direct light going into the rectangle room through the slits
Decided to do a comparison test with Arnold for Maya using the exact same mesh, but with Arnold’s Physical Sky system

UE4 Directional Light - the side walls that receive bounce light from the direct beam hitting the back wall, looks odd. The indirect influence is not aligned with the direct beam.

Arnold (Maya) Physical Sky - the side walls that receive bounce light from the direct beam hitting the back wall, looks more natural here. Settings - Diffuse ray depth of 10

UE4 Directional Light - The indirect influence is not aligned with the direct beam.

Arnold (Maya) Physical Sky - besides the light color not matching, the indirect bounce looks more natural here. Settings - Diffuse ray depth of 10

My settings are;

.ini
[DevOptions.ImportanceTracing]
NumHemisphereSamples=512 (reduces noise from skylight)

[DevOptions.PhotonMapping]
NumIrradianceCalculationPhotons=2048 (this doesn’t seem to change anything for me even when at default)
IndirectPhotonDensity=12000
IndirectIrradiancePhotonDensity=8000
IndirectPhotonSearchDistance=240 (also tried 200, 180, 100, 50 - no difference)

world settings
Static Lighting Level Scale = 0.1
Num Indirect Lighting Bounces = 20
Indirect Lighting Quality = 10
Indirect Lighting Smoothness = 1.0
Compress lightmap - off

Static mesh lightmap resolution - tested with 128, 256, 512 (same results as above)

I’m aware that Ray tracing for UE4 is coming ‘soon’, but I’d like to be able to solve this issue with the current lightmass tech. Not all projects will be on Ray tracing yet. This is a very simple scene…so I don’t understand why I’m facing this issue.
I hope someone with more experience can chime in on this issue that I’m having, thanks.

The UE4 lighting doesn’t look wrong to me, just looks like the shadow is perfectly sharp

I’m referring to these areas;

comparison01.png

comparison02.jpg

Notice that there’s this “extra” spill of indirect light that’s not lining up with the direct beam of light.

Besides this issue, the shadows at the intersection of the walls seem abit too strong/crisp to me but that’s more minor.

I’m looking at these areas specifically;

comparison01.png

comparison02.jpg

There’s clearly an extra bit of bounce light that does not line up with the direct light hitting the back wall. The Arnold GI looks more natural.
The strong/crisp shadow at the wall intersections is a minor issue.

Now that you pointed it, the leak is quite obvious. Is the geometry in that area overlapping in some way? Is that wall a flat plane? AFAIK lightmass uses a radiosity cache to store photons and speed up GI computation at the cost of definition on small details (the world scale param control how fine/coarse the cache is), I wonder if that’s related to this case.

Yes, geometry is overlapping a good bunch - 10-20cm. The walls have planar faces.
My settings above are quite high already. Static Lighting Level Scale = 0.1 will result in a detail lightmass bake

Hi!

I’d say there is no need to touch the baselightmass.ini anymore for great results!
Are you using portal in your opening?
Unrelated (maybe) but I wouldn’t go higher than 10 in bounces: after 10 it’s kind of random and can cause strange results)
Your smoothness is on 1 which means Unreal will blur out most of your details… you can get even shading differences…

For best results don’t use overlapping faces: it can produce shadow bleeding! Corner/edge snap your walls or from your lightmap uv cut out those overlapping parts!
If you want small and realistic results: you’ll nedd to go higher with your lightmaps!! (1024< per wall!!)

There should fix your errors!

  • if your walls are just planes and not 3d meshes you will also get unpredictable results!! Use meshes with thickness!!

been awhile, busy with stuff…but gotten back to this scene

@Makigirl

tried using portal - same results
bounces - no difference whether 10 or 20
lighting smoothness - lowered to 0.25
meshes are snapped, no overlapping faces
lightmap resolution - bumped up to 1024, same results
wall are obviously 3d meshes, else the light would just spill in from behind

what I found out is that directional light is the culprit for the light getting stuck in those corners.
just baking light with a skylight turns out fine, except for the overly dark “ao” at the corners.


Hope a dev can take a look into this regarding light bakes.
Although I know RTX is here with 4.22, but the GI implementation is still not ironed out atm so I’m using a combination (baked lighting for GI, RTRT for shadows)