Lightmass crashes every build

Hey, I just recently started developing and am trying to become more familiar with UE4. I have been trying to use the BUILD tool as I have multiple objects inside of my map that require building. But I am consistently getting an error that says:

=== Lightmass crashed: ===
Assertion failed: Importer.ImportData((FBaseMaterialData*)this) [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.10\Engine\Source\Programs\UnrealLightmass\Private\ImportExport\Material.cpp} [Line: 14]

I am using imported 3DSMax models if that helps at all.
If anyone could help that would be awesome. I have tried clearing the swarm agent cache but I’m unable to open it through my task manager.

Hi Entropikz,

Can you try the following things and see if you’re still getting the error:

  • In the Epic Games Launcher under the Library tab where your Engine tabs are. Can you click the down arrow next to the Launch button and select “Verify”. This can potentially fix any issue with the engine that may cause this.
  • If that doesn’t work, can you open Swarm Agent after trying to build lighting for your level. You can find it’s icon in the task tray next to the clock in your Windows Task bar. It’s the Yellow/Orange SA icon. Once opened click the Cache menu button. then click Clean and then Click Validate.
  • If that doesn’t work, Try creating a new default level. Do not place anything int he level other than what is already there. Click Build to build the lighting. If that works, add one of the meshes you mention in your post and see if that can build lighting. If that causes the failure we can try and narrow down what may be going on with the asset.

Thank you!


1 Like

Thank you for the response Tim,
I’ve noticed that none of my imported meshes cause the crash. It seems to be caused by adding actors such as cubes and spheres into the game world. I’ve pulled in every other mesh without error.

Can you try the steps in the guide below and change the log verbosity to Super Verbose

Once you build and get the error can you copy and paste the log into a text file and upload here? Maybe there is something in this that I can see that may point to the issue.

Also, were you able to Clean and Validate your cache? You had mentioned in the original post that you couldn’t open from your task manager and no mention in your last post.

It may also be helpful to get your DxDiag, so if you could attach that text file here as well I would appreciate it.

Thank you!

I can’t seem to get swarm agent to run on my computer. When I run the .exe it’s only allowing me to exit the program. I can’t open the cache or anything. Could it be a problem with my install? When I tried to validate my engine version it crashed my computer the first time. The second time it froze on 98% and I had to close the program.

Can you post your DxDiag here? This file includes your system specs and driver information that could be helpful in seeing if anything stands out.

You may want to try re-installing the engine. If you’re not able to open the Swarm Agent in Windows without the program crashing that could be a problem with the installation, that the VS2015 pre-requisites are not installed properly, the .NET framework is not up to date, and probably a couple of other things to check as well.

Give the re-install a try and see if that resolves it.

I’ve realized that it’s an issue with my computer. I must have burned out a harddrive somehow because my OS won’t update and that’s causing my issues when I try to re-install. I’m going to upgrade soon anyway, so I’m hoping that after that I will have better luck with getting this resolved. Will I still be able to access my project with a new install?

Oh that sounds like no fun at all. :frowning:

You shouldn’t have an issue using your project file again. You will just need to make sure to backup your project folder in a location you can still access. When you install the same version engine or a later version you can simply open the engine. If the engine version that it was developed with is not installed, you will see a window pop up that looks like this:


It will contain a drop down for all the current versions of the engine that are installed.

Once you’re back up and running if you’re still having the issue feel free to post back here and it’ll re-open the questions and we can investigate from there or if you have other questions with this topic that’s fine too.

Alright, I’ll open this back up as soon as I have everything figured out. Thank you so much for helping me with what you can. I definitely learned a lot going through this process. Have a good New Year man.

Just an extra note :
If your PC just shuts down building lighting, try reducing the Lightmass.exe Task manager, Go to Details > CPU Process priority = Low (and use Prio or similar to save that)

  • this reduced crashes for me at least
  • prolonged 100% CPU used and high RAM demand (like 29/32gb) can overheat your PC to the point where it may shut itself down

,Clearing the Cache in Swarm Agent worked for me, THANKS

1 Like