Lightmass crashed

Hi all!

I’m trying to build the lighting in my scene, but all I get is the well known “Lighmass crashed” Error

Error === Lightmass crashed: ===
Assertion failed: (Index >= 0) & (Index < ArrayNum) [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.8\Engine\Source\Runtime\Core\Public\Containers\Array.h] [Line: 678]
Array index out of bounds: 3295442 from an array of size 3295442

KERNELBASE.dll {0x00007fff65ab606c} + 0 bytes
UnrealLightmass-Core.dll {0x00007fff2624edbf} + 0 bytes
UnrealLightmass-Core.dll {0x00007fff26131738} + 0 bytes
UnrealLightmass-Core.dll {0x00007fff26112778} + 0 bytes
UnrealLightmass.exe!Lightmass::TkDOPTree::SplitTriangleList() {0x00007ff74ff160b8} + 0 bytes
UnrealLightmass.exe!Lightmass::TkDOPTree::SplitTriangleList() {0x00007ff74ff16714} + 0 bytes
UnrealLightmass.exe!Lightmass::TkDOPTree::SplitTriangleList() {0x00007ff74ff16714} + 0 bytes
UnrealLightmass.exe!Lightmass::TkDOPTree::SplitTriangleList() {0x00007ff74ff16714} + 0 bytes
UnrealLightmass.exe!Lightmass::TkDOPTree::SplitTriangleList() {0x00007ff74ff16714} + 0 bytes
UnrealLightmass.exe!Lightmass::TkDOPTree::SplitTriangleList() {0x00007ff74ff16714} + 0 bytes
UnrealLightmass.exe!Lightmass::TkDOPTree::SplitTriangleList() {0x00007ff74ff16714} + 0 bytes
UnrealLightmass.exe!Lightmass::TkDOPTree::Build() {0x00007ff74fec219c} + 0 bytes
UnrealLightmass.exe!Lightmass::FStaticLightingAggregateMesh::PrepareForRaytracing() {0x00007ff74ff049ba} + 0 bytes
UnrealLightmass.exe!Lightmass::FStaticLightingSystem::FStaticLightingSystem() {0x00007ff74fea252f} + 0 bytes
UnrealLightmass.exe!Lightmass::BuildStaticLighting() {0x00007ff74fec2aca} + 0 bytes
UnrealLightmass.exe!Lightmass::LightmassMain() {0x00007ff74feff3b8} + 0 bytes
UnrealLightmass.exe!main() {0x00007ff74ff1d94f} + 0 bytes
UnrealLightmass.exe!__tmainCRTStartup() {0x00007ff74ff7950b} + 0 bytes
KERNEL32.DLL {0x00007fff683616ad} + 0 bytes
ntdll.dll {0x00007fff686c4409} + 0 bytes
ntdll.dll {0x00007fff686c4409} + 0 bytes

Hey vnmber,

In order to assist you with this issue I am going to need a bit more information. Would you mind taking a look at our How to Report a Bug sticky post on the Forums?

It will give you all the correct instructions on how to make an official bug report on the AnswerHub including all the information we will need in order to move forward with the reporting/troubleshooting process.

Let me know if you have any other questions and I will be glad to assist you.

Thank you,

Andrew Hurley

Hi Andrew!
Thanks for your reply. I maked a copy from this project, now everything is ok, build is work, without error.
Thank you!

Zoltan

To add to this post, if you run into any Swarm Agent/Light building issue, we also have the Swarm Agent Troubleshooting guide that can help with some common issues.

This one is listed here: Assertion Failed:

Hi!
The problem came out again unfortunately.
A clear swarm agent and validate, but the problem is not solved.
My computer: i72600k, 24GB ram, GTX 750 Ti.

Here is the swarm agent log.link text

Hey vnmber,

Would you mind providing me with a quick screenshot of your scene you are trying to build?

I am looking in particular for a Lightmass Importance Volume, as well as the amount of geometry in your scene. If you have a large level and a large amount of meshes, try increasing the ‘Static Lighting Level Scale’ found in your ‘World Settings’ tab.

Thank you for providing me with your SwarmAgent logs.

Cheers,

Andrew Hurley

Hi Andrew!
Thank you for your reply.
Here is some screenshot of my scene, and one original picture from original project 3ds max vray.
I tried increasing the Static Lightning Scale , but did not help, the build is down with same error.
Thank You.

Zoltan

Hi Andrew!

The original 3ds max project was 14.000 000 polygon. I would have liked doing this with the original high poly models, in unreal engine. Unfortunately always was error when I try build the project.
I decrease the most high poly model to low poly in scene, now everything is ok, build is work, but this method is takes up very much time, and very exhausting.
But works at least…
Thank you.

Sorry for my english…

It seems you have it toggled in ‘Unlit’ mode in your screenshots :slight_smile: