Lightmass Crashed (Process cannot access the file..)

I’m doing an archviz scene and I’m unable to build the lighting.

I’m sure it’s not a hardware issue since the same project (from the same usb hdd) builds just fine on my inferior machines, but not on any of my powerful ones.

All my meshes have been optimized to be as light as possible and all my lightmaps go up to a maximum of 512x512, with the majority being 128x128.

I’m including my SwarmAgent Log

After a long research here and google, here’s what I’ve tried so far:

  1. Uninstall + Reinstall Unreal Engine
  2. Copy + Paste Unreal Engine from working machine to others
  3. Clean + Validate SwarmCache + delete everything in the appdata/unreal folder
  4. Migrate whole project to a new project
  5. Migrate whole project except lighting to a new project
  6. Reinstall all .NET stuff
  7. Copy the project to a local folder
  8. Run everything as Administrator

May I add that in the log,

ChannelName, EChannelFlags
ChannelFlags) in

refers to D:\Perforce\Epic…, while my UE4 is installed on C:\ and I’m not using SourceControl or Perforce.

As I already mentioned, the same project builds just fine on my slower machines (less cpu, less ram, less gpu)

Please help!

I’ve been struggling for the past week.

Hello AlBlunty,

I have a bit more information I would like to get from you in order to narrow this issue down.

1.) Can you link your DxDiag of the machine that you are having this issue on?
2.) Are you using a GitHub version of the engine or the one from Epic’s site?

As soon as I have this information I can start to narrow down where this crash is occurring. Also if this engine does crash there will be a screen asking you to submit your logs. If that happens please submit your logs with a brief comment of how this is happening. That information is then sent to our database where we can track this crash and then assign it to a bug or to be looked into by one of our developers.

Thank you,


I’m attaching my dxdiag.txt file as requested.
Unreal Engine itself doesn’t crash, only the Lightmass does.
I’m using the one I installed with EpicLauncher.
It used to work fine on both machines that aren’t working now and all of a sudden I get similar errors.
I haven’t updated or changed anything in UE4 or Windows, nor hardware wise.

Hello Abluntly,

I do not see a compatibility issue as your graphics card does support Directx11, which is our recommended specs for running UE4. I do see that the driver date is labeled as 1.10.2015.

I suggest to see if your drivers are up to date. I seem to recall a more recent date for that Driver. After this if it still happens I will try and recreate this issue on my my end.

For that I would ask for a test project that this happens in. You can send me a .zip here on this thread. Or you can send me a private message on the forum. If you do this please send me a link from dropbox as we do not have access to other file sharing networks.

Thank you,

p.m. sent!

Hello Alblunty,

Thank you for sending the files. I was able to open them up on my machine. Whenever I open up any of your levels what I see is the light build getting to a certain percentage and never building past that. Whenever I look at the swarm agent where the lightmass is being built then it is building as I would expect.

There is a bug currently being investigated in 4.9 that handles this exact same issue. Currently it is random and effecting multiple people across different projects.

I am adding this thread to the list of users that are currently seeing this crash/lighting build bug. Hopefully this issue will be resolved fairly soon.

The ticket number is UE-20782.

I will keep you up to date on this bugs progression.

Thank you for reporting this,

I just tried net-rendering with my two working machines (SwarmCoordinator) and I got the same error as I was getting on the two machines that don’t work.
It worked just fine yesterday.
Again, no updates/upgrades on any of the machines.
Building Lighting on a single machine (one of the working) works though.