Download

lightmass banding?

so I’m making an archviz project of a whole house, with regular sized windows (not those enormous glass panels that every archviz tutorial has) and just sun and sky lights, so you can imagine that the rooms that don’t get direct sun light are having a bad time dealing with lightmass. I never managed to get useable light maps even for the well lit rooms until now, had to manually unwrap everything, manually set map sizes, but after I spent a lot of time messing around with lightmass and watching videos, I finally got decent results for my this bad lit scene.

except for the walls. there’s this noticeable banding:

I mean it’s clearly pixelated, but if you notice the sun light is not nearly as pixelated as thesse big clear rough edged squares abd this color banding on the walls. and even though I packed many walls together in the same uv map, their resolution is 2048px. so it really shouldn’t be a problem with resolution?

what could it be?

ps.: this was baked in production quality, with some lightmass settings overrides, such as 1.1 for static lighting level scale, 5 num indirect lighting bounces, 2 num sky lighting bounces, 1.1 indirect lighting qualityt, and 1.2 indirect lighting smoothness. swarm says it took 1,32e+04s to render and I have no idea if it’s 13200, 1320 or how many seconds but I’m assuming it took a long time, since I left it baking overnight.

ideas?

Hi!

If you want crisp clear quality why would you pack walls together and assign 2048 lightmap res for them?!?! :S
And your Lightmass settings are WAAAAY too low for an archviz scene!!
0.1 for scale, both bounces 5-10, (you have 2 bounces of Skylight and you complain about it’s quality?), quality somewhere between 4-10 (!!!) and smoothness 0.6
With your current settings all you get is a big blurry inaccurate result!!

…I’m also guessing you’re using compressed lightmaps…

hey! thanks for answering

well, mostly because I’m totally unaware of how to setup things properly. I saw once somewhere that wall corners are better if their uvs are stitched together, because otherwise the lighting could be really different from one wall to the other and look weird on the corners. the 2048 res is me trying desperately to figure out why my lighting looked so bad, so I tried increasing the resolution. didn’t help much. is it overkill? if you had some big L shaped room, would you separate the walls and have them in different uvs? and what resolution for the light maps? edit: I just noticed viewing lightmap density that all my maps are red, but not just red, solid 100% red since the uv squares on the red are so little they can’t be seen lol. perhaps it is a little overkill. should I go for yellow? orange?

after posting this, I did another bake that took about 4 hours, with some different settings and without compressed lightmaps. it looks much better and mostly fixed the issue, but I’m not sure which setting fixed the issue. and now I’m having messages saying texture streaming is over budget or something, so maybe resolution of my lightmaps are too big.

I’ll definitely try using your settings, thanks again!

In an L shape room I’d break up walls (well basically any kind of mesh) at hard edges… you can then exclude all the overlapping/unseen parts and just keep (and scale up as much as possible /doesn’t have to be uniform/)! If you want to be super accurate you can set a checker map (chosen resolution) in the background of your uv editor and snap all to corners.
Then you can set different resolution for each wall (depends what you need, how much lighting information will be needed). Many but lower resolution lightmaps are faster to calculate than one huge one.
Red doesn’t really mean anything… Unreal was meant to be for games not archviz. You’ll see if your supposedly straight shadows are pixelated or not…

Also if you want a more automated and faster renderer you should check out the GPU Lightmass…

I did check gpu lightmass, but people are reporting issues with unreal 4.22, so I’m waiting until a stable version to try it out.

so, I did try the settings you told me, but after 5 and a half hours calculating, swarm finally gave up at 2%!!! that’s the reason I never managed to mess around and learn lightmass settings in first place, it’s not because it’s slow, as I could leave it rendering for days, but because swarm simply stops after a while. and I’m on a ryzen 7 1800x, it’s not a slow processor or anything. it’s out of my understanding why this happens

guess I’ll try remapping my lightmap uvs and scaling down my lightmaps to yellow.

:S
What I would try: keep 2-3 of your main walls on high res lightmap and set everything else to a very low one! This will speed up your light building time and you can concentrate on your problematic area…
Also for the tests you can build in medium quality and lower indirect lighting quality in lightmass settings (4)… You should still get very nice results…

that’s what I’m doing right now. it seems to be working, however currently my scene has no outdoor, nor furniture, it’s just the exterior and interior of the house. I optimized the uvs and all the faces, deleted almost everything that is not directly visible. I’m just scared that when I put everything on my scene it will not be able to render at a decent quality. but that’s still not happening for a while.

let me ask you another thing, quality-wise, what’s the difference between a static and a stationary directional light? I was rendering with my sun as static, but I’m planning to add some interaction for the doors, so I tried stationary and the shadow borders are looking weird, way more pixelated than static, and this is not around any movable objects

Hi!

Just in case you want to pack your scene later, keep in mind there is a 2 GB limit/ level I think… if you have a big house with lots of rooms + objects, try to split it up into smaller levels for streaming…
About stationary lights… I think you should read this:

Although it says it’s the best quality light I like the result of the static one… to me that is much nicer…
Anyway they say the specular reflection is a lot nicer…
Also you can get distance field shadows and shadowmaps which can be really useful!! …you should read the documentation! :wink:

it’s not that big. it’s a regular sized home, two bedrooms, but maybe it’s big for real time. Idk, breaking it into levels would break the feeling of exploring the house as a whole, which for me is one of the great things about real time. i’ll try to keep optimizing maps and see what happens, maybe it won’t come to this.

yeah that’s a nice tip. I’ve been reading A LOT of stuff from the docs and also watching a lot of vids. it’s just that sometimes you have to read exactly what you need, and it can be hard to find, so luckly there’s helpful people on the forums like you.

what I noticed about the stationary lights is that the shadows appear to have more definition on hard edges, but the lightmaps appear to have become more pixelated too. with stationary lights, I didn’t manage to get results as good as using static lights yet, even in production and with high values for the lightmass settings.

do you have any tips for good looking integration of movable objects (let’s say a door) and baked lighting? in direct sunlight, the integration is great, the door casts shadows just like the static objects in the scene, and the light it receives and shadows cast on it are acceptable. however while on the shadow, being lit by indirect lighting only, movable objects stand out, as if they are shining, emitting light themselves. is there a practical way to mitigate this discrepancy?

I think we all learn like this… and you can run into interesting/useful things where you don’t even expect! :wink:

Maybe your cascaded shadowmaps are the pixelated ones!! You should check your settings! They should help to get away with a better resolution than a lightmap could handle…

No, sorry, I never had to work with “interactive” scenes…