LightmapUV Error causes packaging failures in 2D Mobile game

Hi UE4 folks,

I have been having some packaging errors with my game. I always do a full rebuild with packaging. I am trying to test the game for development before I package for shipping. There are 2 majors problems in my packaging failure logs.

  1. Engine/EngineDebugMaterials/MAT_LevelColorationLitLightmapUV has a LightmapUV Node that is not compatible with mobile games. (as seen in the picture). However, I do not know how to disable it or change it to a compatible node.
    This is stopping the material from compiling properly.

  2. /Engine/Tutorial/SubEditors/PersonaAnimEditorTutorial is not being found during packaging.

These are the first two failures in my logs.

Any ideas on how I can fix the broken Node, and tell the engine to stop looking for Tutorial.

Aside from that I have some other files I want the engine to not look for during packaging, they are all assets of a GUI package that I am not actually using in my game. Im only using a few assets from the GUI pacakage, but the Engine always looks for the non-used assets during the build/packaging which causes me to get a bunch of “Can’t Find File warnings”

thanks in advance for your help.

Hi Mr. ,

Regarding the “PersonaAnimEditorTutorial” asset, this was reported in-house and fixed for UE4.10. However, if you do not wish to update your project, which may cause additional issues, you can correct one line of code in the engines BaseEditorSettings.ini found here (Likely on your C Drive where it says D here):


…and here is the line.Changing the “+” at the beginning of the line to “-” or deleting the line altogether and saving the document. (Perhaps copying and pasting line in a separate doc, to put back, just in case):

As for the MAT_LevelColorationLitLightmapUV, the “LightmapUVs” node is not compatible for mobile projects. Replace this with the dual-channel output vector value (0,0) as shown here:

*Source: [虚幻引擎坐标材质表达式 | 虚幻引擎5.2文档][4] *Select “translate” if this is not link in English.

you are always a great help. Truly appreciate it.

unfortunately Im still getting the same “PersonaAnimEditorTutorial” asset error after I have changed the line of code. I used each method. Changing it to a “-” and deleting the whole line.

I also created re-opened the project in v4.10 since the bug had been fixed in the upgrade. It created a new error of course, the “Unable to generate long package name” “FilenameToLongPackageName” error.

Make a back up of then try deleting your intermediate and saved folders so that the EditorSettings in your projects Config folder are rebuilt from the BaseEditorSettings you made the change from. Likewise, after you do this, make sure the following line has been removed in the “EditorSettings” located in [Your Project] Intermediate>Config>CoalescedSourceConfigs>EditorSettings:

The following line should be removed after rebuilding your intermediate and saved folders: "TutorialContexts=(Context=“Persona”,BrowserFilter=,AttractTutorial=None,LaunchTutorial=/Engine/Tutorial/SubEditors/PersonaAnimEditorTutorial.PersonaAnimEditorTutorial_C)

In short, after you delete the intermediate and saved files (with project closed) open the project and these files will be rebuilt with the change you made to the BaseEditor Settings

So I followed those steps and still kept getting the same “failed to find” error. Then I decided to go check the defaulteditorsettings.ini for the project, and I saw that there was still a call being made for “PersonAnime…Tutorial”. I changed the “+” to a “-”. I deleted the intermediate and saved files for a rebuild.
This was able to correct the “failed to find” error. However, the packaging still failed. Here is the log: Dropbox - File Deleted - Simplify your life

There are a number of “failed to find object” warnings but those are all for assets that are present in my game but that I dont actually use during any game play. I’m not sure if this could be causing the fail. Even when I remove those objects from game all together, I still get “fail to find” warnings.

In the projects “Binaries” folder I noticed that I had some old cooks/builds. Could the presence of old files be causing some confusion in my build?
Is it safe to delete them?

You could temporarily move the old builds to a separate folder and see if this helps. You can also tell what to include in the ini files that lists these assets or delete them altogether if not used in the game (after you’ve made a back up of the project folder of course.)

Those last few steps helped me learn the engine a lot better and definitely fixed some bugs.

However, the final answer to my packaging issue was found here: Android project name causes ant.bat error - Platform & Builds - Epic Developer Community Forums

In the project settings>platforms>android, the “Android Package Name” still had the “[…]” around the project name. When I removed them the packaging worked perfectly.

Thanks again. Your help was invaluable.

Thanks for sharing your solution.