Lightmaps updating slow when moving thw view

Hi everyone,
I’m super new to unreal engine and I really don’t know much about light baking, I followed a tutorial to bake lights with GPU lightmass into a test scene with heavy geometry and minimum amount of windows, the baking looks ok when looked from a close position ( if we don’t consider a few light leaks maybe due to the fact that some complanar objects are not attached). However when I rotate the view fast I see black spots and leakes (maybe due to the lod of the lightmaps?)

what is this effect due to, and how to solve it?

this gif should clarify the problem I’m getting
lightmaps

This is most likely due to virtual texture lightmaps. It can take some time to stream in the higher resolution lightmaps and so while its doing that if you don’t have adequate padding around your UV islands you can see seams.

Couple of potential solutions:

  1. Disable streaming virtual texture lightmaps. I wouldnt recommend it, but it will most likely work.
  2. Regenerate your lightmap UVs with a lower minimum resolution. I’d set it a few powers-of-2 resolutions below what you plan to use on the asset. (So if you’re using 512px lightmaps for your asset, you’d set the minimum to 128). This should help obscure the artifact.

Also if you’re not using the latest version of the engine I’d suggest upgrading, as I recall this issue was improved at some point though I can’t remember when.

Thanks a lot for the suggestion, disabling virtual maps worked!

I’m using 4.27.2
Are you suggesting upgrading to UE5?

However I need high res lightmaps because the scene won’t be textured so the light effect needs to be perfectly smooth, furthermore, the scene has a high number of polygons, and I would like to navigate with a VR headset, any suggestion for that?

I am not suggesting you reduce your lightmap resolution, I am suggesting you reduce the minimum lightmap resolution, because that is what will dictate how much padding there will be around your UV islands.

1 Like