Download

Lightmaps too large?

Hello!

I encountered this error when I tried to render my foliage:

Warning InstancedFoliageActor_0 The total lightmap size for this InstancedStaticMeshComponent is large, consider reducing the component’s lightmap resolution or number of mesh instances in this component

Afterwards, my trees or grass looked all weirdly shaded and dark.

I want to have a open area to explore which requires a great amount of foliage. How can I render it so it looks proper?

You could try to split up the foliage into more foliage actors.

And how would that be possible? Does it help with the lightmaps?

Or might the procedural foliage tool be the better option here?

Sometimes it’s better to leave foliage to movable!

i get this warning as well. How do u do multiple foliage actors? When i paint it only goes to the one.

Same issue for me.
Any idea how to multiple foliage actors?

Hi there

Did any of you ever figure out how to solve the problem? Or were you able to find a solution on your own? If you have can you shar please?

This message is just a warning so in some cases it can be ignored if there are no problems. :slight_smile:

As mentioned before already, turn off static shadows for some smaller foliage. Set them to only dynamic shadows. Give those a cull distance so only the visible actors around the player are rendered. You need a stationary sun for that with a dynamic shadow range larger than zero. Check the other static foliage actors for excessive lightmap sizes. Everything larger than 64 can be a problem if you have hundreds or thousands of actors.

Building lightmaps on foliage doesn’t make sense. You need to use multiple levels. Split landscape, foliage and anything that isn’t supposed to get baked into their own level, and then anything that should get lighting baked should be on another level. By doing this, you’re not baking the landscape and foliage. This guy wrote an excellent tutorial for that: Quick Tip #4: How to build lighting in a big landscape.