Lightmaps stuck displaying Lowest Quality

With my scenes I’ve noticed that after the amount of lightmaps hits a certain point, the streaming/mipmap system seems to stop working for lightmaps (as well as textures but they are easily solved by stopping them from streaming)

Since I am using Unreal for Arch Viz, My scenes are normally pretty high quality with lots of large uncompressed lightmaps to get the most quality as the end spec of the project is high and realism is the most important thing. I have had this problem since i’ve started really on version 4.6 .Problem is after a certain level of detail the lightmaps default to their lowest quality no matter what distance you are away like this:

The only solution I have found for this is to go into every single lightmap one by one and setting them to generate no mipmaps, like so

when I do it for all lightmaps its finally back to the correct quality like this:

While this solution works in the short term, it is incredibly time consuming when you have over 1500 to do as it takes literal hours to do.

What I’m wondering is what might be causing this problem and how can I fix it?

It would be incredibly helpful as it would save me hours of time each and every time I rebake. I would also be happy with a solution to turn off mipmap for lightmaps faster as well, i’ve tried turning off streaming project wide which i think also worked but it had a huge hit on the FPS where as just the lightmaps didn’t really effect it.

Thanks for the help

This should be configurable with device profile.

In editor open Window > Developer Tools > Device Profiles. There you will find settings for every platform. In case your platform is Windows, press button on TextureLODGroup settings next to it, find Lightmap and Shadowmap there and set its mip gen settings to NoMipmaps.

Then press Save As Default on top of 1st window.

Hope it helps.

Hmm I’m not sure if this helped, New lightmaps didn’t default to no Mipmap but it didn’t visually make a difference but then again I found out what the problem was anyway but thanks anyway

Right I found the answer. I forgot I had put a node to disable all screen messages a while ago and didn’t notice I was way over the default texture streaming pool size. Once I upped it with console commands all the lightmaps snapped back into their correct Mip.

Also for fun do you want to know how far over my texture steaming pool size I was? 5gb.

5 Whole gig over the default haha