Lightmaps are set to a low value after build lighting

Hi there! I hope someone can help me with this

When lighting is built lightmaps of all static mesh in the scene change from a 128, 256, 512 or any value to a low resolution like 4 or maybe 8 automatically, but if I look in StaticMesh Editor, resolution hasn’t changed. In Lightmap Density Viewmode, before build lighting lightmaps are green, after build lighting, lightmaps are blue but if I move them 1 unit becomes green again, but if I move them I would have to build again…

Each Static Mesh Lightmap have been created with 3dsMax and lightmap coordinate is set in correct index in Unreal. If same Static Meshes are imported to other project and lighting is built problem doesn’t appear…

I have tried to :

  • Change resolution from “Overridden LightMap Res” in Details panel instead of Static Mesh Editor.
  • Create a new Level
  • Reimport StaticMeshes
  • Set defaults World Settings…
  • Generate lightmaps with Unreal

Sorry if my explanation is not good at all, but english isn’t my natural language.



I’m having the same problem with a project I’m working on. The file has one main level and two sub-levels. One of the levels contains the studio pictured below.

I set all the Lightmap resolutions individually, so they are coded green. However, when I build the lighting – using all static lights, the preview shadows effectively disappear – with no shadowing/baked GI in the scene at all?

I’ve tested this with both Stationary and Static lights, and Spot, Point, and Rect Lights. Each renders flat after building the lighting solution.

It may be worth noting the levels are not set to streaming. There appear to be no Volume Lighting Samples visible in the Viewport Show Flags?

I wonder if you solved this?

All the best.