Lightmaps and LODs

Hi there!

I have an issue with lightmaps when used specifically with LODs. Here is my scenario: I made a model with two LODs. Both models share the same normal and lightmap unwrap with spacings done in such a way that at maximum reslolution (64x64), there are no lightning leaks. Then I build the lightning and everything looks ok when I am near (and I have dynamic lightning disabled at short distances as well) but when the LOD switches, the leaks appear. This is because LOD 1 automatically has lightmap resolution 32x32 and the Lightmass REBUILDS lightning for each LOD. For now, the solution to the problem is to make the mesh InstancedStaticMesh that does not support unique static lightning for each LOD, where everything works fine.

I have two questions:

  1. Is there a way to disable (per mesh or per project) the generation of unique static lighting LOD and only generate lighting for LOD0 as is done for InstantStaticMeshes?
  2. How are we supposed to approach this problem in the current situation: change lighting UVs for each LOD I guess? (isn’t this time consuming + you would need to merge certain parts to avoid the leaking problems)


I second this, I would also like to have a single lightmap calculated per staticmesh and have all the lower LODs use the LOD0 lightmap. Of course mip mapping would lower the effective resolution, but the inconsistencies would be fewer.

I would prefer an option to set the lightmap resolutions individually per LOD, instead of having a default 32x32.
Having different lightmaps for different LODs can be usefull if the geometry changes a lot between LODs.

Hmm I was frankly sure that lightmass does lightmapping only for LOD0

I guess in certain situations, each LOD having its own lightmap generation might be useful. But the main problem is that as you reduce LOD, you should also increase spacings between islands (i.e. totally change lightmap UVs) to avoid leaks. There are no problems if you just use LOD0 texture downscaled if the geometry stays approximatelly the same. I would just like an option (or a simple hack to Lightmass) that would override this default behaviour that doesn’t work well for me.

Did you manage to find a workaround for this?

It seems UE4 can do lightmapping for all individual LODs.
Please check:
UnrealEngine/StaticMeshLight.cpp at release · EpicGames/UnrealEngine (

@ziga.osolin Hi did you find a workaround for this issue?