Lightmap UV channel being ignored by Lightmass

I have a mesh which has 2 UV channels - the first one (UV0) is heavily overlapping for texturing purposes, and the second one (UV1) is a lightmap, and is not overlapping at all.
I have set Lightmass Source Index to 1, and Lightmass Destination Index to 2. This should work, right? It is working on all the other meshes, except this one. “Generate Lightmap UVs” is disabled as well, however enabling this will fix the problem, but I do not want to rely on the generated UVs, as I have had problems with those before.

You can download the mesh in question here: Dropbox - File Deleted

Hi Arrays,

You still need to set the Lightmap Coordinate Index to 1 in the Static Mesh Settings > Lightmap Coordinate Index.

The Build Settings only generate the UV but do not automatically assign it in 4.12. I believe this was either correct in 4.13 or will be fixed in 4.14, which you can check in these versions since they are available in the Launcher.

-Tim

This fixed the problem. Thank you for the extremely quick response!