Download

Lightmap quality at distance

The lightmap resolutions seems to be lower before you approach the mesh, then the dark marks seem to disappear on my scene as I approach them. I’m guessing this is the lightmaps going to a higher resolution?. How is it possible to change this so it is always high?

Yes by setting the texture quality to max =)
Capture.JPG

@richardek

I’m not sure that’s the best option here since this is just a quality settings that controls all textures for streaming mip bias, max anisotropy and the streaming pool size. This quality setting doesn’t stop mips from working though so the streaming for textures would still happen including lightmaps.

@Imsopov

Some things to consider for lightmap streaming issues.

  • If you have a lot of lightmaps that streaming in for your assets with higher lightmap resolutions this can use a bit of memory or take a bit to load in fully for the best quality. If you loading the level and using a loading screen add an additional couple of seconds or whatever amount of time to let everything fully load in.
  • If you wanted to disable texture streaming on lightmaps specifically and you have the room for the texture memory you can make modification to the engine to make this happen. Otherwise, you can set them in the editor by opening each Lightmap Texture and setting its Mip Gen Setting to No Streaming, but then you woul dhave to do this anytime after a light build since these are regenerated.
  • Lastly, you can try adjusting the console command value for LightmapStreamingFactor (0.000 (lower values makes streaming more aggressive) to a higher value.

Thanks a lot for your suggestions. I’ll try some of them and see what works best

Wow that was how you actually do it!
Thanks [MENTION=4894]Tim Hobson[/MENTION]