Download

Lightmap Problem / Black Object after Rebuild (Blender Import)

Hey guys,
I tried to import my “apartement” built with blender into UE4.
In Blender:
c61453064c5acf5b8fc58e9ba0a523deda93f7f7.png
Many guys said, that I need to make a Lightmap in Blender, but normally, UE4 could generate it itself.
Then I’m exporting it as a .fbx file and import it into ue4.
96a9a58041e3d631c146a52a11c2a3cf9085d0be.jpeg
Thats how it looks before building ligthning again.
After that, it looks like this:
5efdd897218afd62583112775c63c49d6d52bf77.jpeg

Okay, so. I need a Lightmap i think. So i’m going to the mesh editor and build a new lightmap, but there is none.
096b1049a06a6c3dd28762816ccc5935f190c0eb.jpeg
Whether in UV Channel 0 nor in Channel 1…

Okay okay… So I tried making a lightmap in blender.
First Channel, just a “Smart UV Project”
ss (2016-07-10 at 03.58.23).png
then in the second channel i pressed “lightmap pack”
ss (2016-07-10 at 03.59.09).png
Then there is a weird and very complicated lightmap, but hey, I’ll give it a try.
ss (2016-07-10 at 04.00.36).png

Okay, exporting it as a fbx and importing in UE4
ss (2016-07-10 at 04.02.30).png
then there’s a smoothing group error, but i dont think that this is the problem and now its compiling shaders because of all the new textures.
Drag and drop the object on the scene:
ss (2016-07-10 at 04.04.05).jpg
building lightning:
no errors, compiling all shaders and…:
ss (2016-07-10 at 04.08.15).jpg
ss (2016-07-10 at 04.08.26).jpg
ss (2016-07-10 at 04.08.32).jpg

Looks quite good, but you can see some strange shadows (at the pillow and so on…)

Can anyone tell me how i can remove these shadows?

Thanks for all advices! :slight_smile:

If you’re using one lightmap for that entire scene that is most likely the issue, combined with the small dimensions you are currently using. Try breaking the scene up into smaller pieces with their own lightmaps, or increasing the lightmap resolution size. Also ensure that you don’t have any overlapping lightmap uv’s.

Also double check under material for import it’s not generating uv lightmap and on the mesh options you tell it to use the lightmap channel 1 if that’s the lightmap.

Is the house one single mesh? That’s not the way to do game ready 3d environments. For starters it would be best to split the furniture into separate meshes and export them separately. The walls and floors could be made using BSP in the engine.

Hey Thanks for all answers! I seperated the rooms into furniture and so on, but now i keep getting black shadows at the borders of single faces… Something like this:
18ec87d542765271fda75cb83042c3fa145522b1.jpeg

hm… Increasing the resolution of the lightmap seems just to make the shadows between thinner and more detailed.

Hey it didnt work :confused: see post before :frowning:

Either those faces aren’t joined, or you automatically laid our your UVs. Make sure that the edges are merged, and show us your lightmap UVs for the bed and pillow.