Lightmap issues with crossing meshes

hey guys,
I have a question “again” about light maps, especially how to handle them when meshes are crossing each other.
I have created a window which basically is made from two meshes, the outer frame and the inner frame with glas, the problem is easy to see, i get some lightmap issues where the inner
frame crosses “goes into” the inner frame. Is ther any way to get rid of this big black spots ?

What does your light map UVs and wireframe look like?

They are almost perfect laid out, pixel acurate on a 512* resolution. When seperating both meshes, they lookj just perfect, no bleeding no issues nothing…
All dark spots are areas where 2 meshes cross each other…

That might just be the ambient occlusion. But ultimately, you’d want to avoid intersecting because the parts that aren’t visible can bleed shadow onto the parts that are.

It’d still help if you posted them, intersecting meshes often have light mass issues, I’d try disabling AO in the light mass settings, or actually modeling the intersections.

I have turned AO off in the light mass settings, but sadly it’s no a AO problem.

Thats the mesh in 3ds max, i have marked the areas where the meshes are crossing.

Bascially it is not a problem to cut the crossing areas off, with the ProBoolean tool in max, the only problem is that a 400 tri strong mesh becomes over 3000 tris by cutting this areas off “or sperating” them.

That’s a lot of polygons for a window, is this for an architectural visualisation type project or for a game type project? Either way I’d suggest trying the merge method, but if it’s for a game, you could really get away with using a much lower polycount.

It’s for a archviz project… However i think 400 tris is not really a lot… But like i wrote before, seperating the two meshes gives me absolut clean and perfect lightmaps. After cutting the overlapping parts off, the lighting looks good, but this can’t be the solution right? I thought i can combine/cross meshes within the UE Editor without getting this artefacts and lighting issues.

For an archviz project it’s perfectly fine, even 3000 isn’t much, was just suggesting with a game, you could get basically the same results with less geo. Lightmass in UE3 and UE4 has never worked great with intersecting meshes, I’ve always had the mesh luck merging or terminating at intersections, because lightmass basically blurs the lit area with the intersecting area, and you get black bleeding out.

This may be old and for UE3, but some of the ideas apply here, particularly the crate example.

There’s also an AO post effect that you can turn off–adjust the settings for that in a post process volume.

Many thanks for the help guys! I will play a bit with the ao settings or maybe remodel the object to one solid mesh.
It’s really annoying that there are so many problems or let’s say points you have to pay attention too, for getting good lightmaps.
Vray like lightmaps would be cool, except of the rendering time…

Bleeding is an issue any baking system will have, since the shadows will be rendered to a texture map. The main thing is that lightmass processes meshes individually, so things like smoothing can end up making visible seams between meshes, but that’s not the issue you’re having.
If the issue is bleeding, then the way to fix it is to either increase the lightmap resolution or remodel that pieces to that it doesn’t overlap. You could actually use a Symmetry modifier and rotate it around the intersection to model it easily.