Download

Lightmap Issues, wall is extremly pixelated. [Images]

THE FIX: Quote from Wilkes; "“Try changing the light that’s casting those shadows to “Stationary” instead of “Static.””

Greetings, as the title states. I have some issues with my lightmaps. My walls are extremely pixelated.

Alright, to start things of… I’ve read a hole lot on how Lightmaps and lightmasses works. I still can’t figure this out.

Some information before I show you all the images:

  • I have a [Lightmass Importance Volume]
  • The light has been built in the Lighting Quality called [Production]
  • There is only one light pointed into the window of the room
  • The Directional Light is just slightly coming through the window.
  • My Engine Scalability Settings are all on Epic
  • I have not fiddled around in any of the .Ini files, I’ve just been working in the engine.
  • There are no errors when I Build my light
  • The Wall is unwrapped correctly, has a great deal of space between the other meshes
  • The Wall has 2 UV Channels one for the textures [UV Channel 0] and one for the Lightmap [UV Channel 1]
  • The Wall is using the correct [Light map Coordinate Index] Which is 1

Here are a couple of images of a wall that is Pixelated and my settings for it:

This.jpg
ScreenShot00008.jpg
ScreenShot00007.jpg
9a81823db1850804fd55055891778c57bcbd21ee.jpeg

Here is the light that is shining up the place.
6b3ccb8f3a2b962e324c8d34002b15ba2565a0cc.jpeg

Here is the Unwrap of the wall:
Lightmap.png

Here are the settings in the Static Mesh Menu for the model, (I am not sure if Static Mesh Menu is the correct name)
feeeed16881272e2781f586f89b53916f497065b.png

Here is an Image of the Detail Tab
d7e1ab27f9cfb7009370aefedb82fdeacf7613e8.png

Here are my World Settings for Lightmass
86277532e0fe1e63063b4a991f2eaf398c66fb07.png

I also tried bumping up the wall Light Map resolution to 2048 built in Production and ended up with this:
3.jpg
c208550c4374dec90a51f9e3f8d093bbd322a34f.jpeg
eb7bbce3a7057acd0ac573bacf0b0a562911ff52.jpeg
c4fd82b1f44e721811741d03f1a4493a89553e36.jpeg

After the FIX:
1.jpg

If you have any more questions, just make sure to type a comment here or send me a private message.
Hats of to the one who is successful to help me!

Try changing the light that’s casting those shadows to “Stationary” instead of “Static.”

Oh my, Oh my! Thank you so much! I would never have figured that out! Finally I can go to sleep!
I will be uploading an image of the result now!

Yet again! Thank you so much, I owe you one Wilkes!

No problem haha! Glad it worked. :slight_smile:

I have same problem, but I cant swich these lights to stationary, beacause there are lots them overlaping, which will cause some of them to set to movable, which will drasticaly decrease performance. If you know another solution, please let me know