lightmap issue?

I have some issue about using the lightmass to bake my scene:

1.What this meaning as the below image shows?

the baked lighting result:

2.If a object placed in the scene has uv overlap error, I just reimport the fixed mesh still has the error. I have to delete the object in the scene and the asset in content browser, then reimport it and put it to the scene again to fix the error. Is this a bug?

  1. Do the objects in the scene instanced from one mesh have the same lightmap? Seems my columns in the scene has same baked lighting.?

Please help!


My guess is your lightmap UV’s aren’t setup very well, current automatic methods whether you use things like Flatten UV’s in 3ds Max, or Generate Lightmap UV’s in UE4 itself do not give good results. The lightmapping tool in UE4 will be greatly improved in 4.5 but until then for the best results you would want to do it by hand. You may need to increase your lightmap resolution, default is 32 which would not be good for that mesh.
You shouldn’t have to delete the object from the scene and the content browser to be able to reimport it, you can overwrite your FBX and then just right click on it in the browser and click Reimport. It should update.
Each individual object in the level has its own lightmap, so every instance of an object has their own lightmap rather than only one lightmap for all the instances of that object.

These tutorials helped me out a lot with lightmapping:

I have flattened the uvs manually before, the uploaded issue image was used this uv:

Reimport didn’t work(btw, the Reimport button will crash frequently, I need to click Import button instead), I just did that as you say. I’m sure I fixed wrong mesh and I can see the right uvs in mesheditor, but when I build lightmap still get the uv overlap error.

@OPreska ,

I’ll check it later.

Thank you all!

Make sure you have the right UV channel set for the lightmap, it doesn’t update to change it if you reimport the mesh.

Looks like there isn’t alot of padding there for your shells. What resolution are your lightmaps? For the best results on your lightmaps you wanna snap your shells to the grid this will eliminate bleeding on parts of your model. If you are using 3DS Max or Maya you will want to go into your grid settings and adjust the grid size or ‘grid lines per unit’. Best way to work it out is divide 1 by your lightmap resolution e.g 1 divided by 64 = 0.015625. Once you get your grid size right give 2 - 4 pixel of space between your shells and make sure they are all snapped to the grid.

@ScrotieFlapWack ,
The resolution I change to 256 still get the artificial, I found it can be smoothness by change the worldsetting’s smoothness parameter, but it will loss a lot of detail.

Maybe I can try your method, but it’s a little complex.

Thanks for you advise!

That is the appropriate method for lightmaps unfortunately :frowning:

That will fix the issue your having though. 256 is pretty high for lightmap resolution, to keep good performance I would say anywhere between 16 - 64 for lightmaps is enough resolution :smiley: