"Lightmap Density" display mode doesn't work well in 4.5?


In 4.4 I can setting the object’s lightmap density on detail panel, and get the result in viewport without building light. But 4.5 it just display gray color?


first is 4.4, second is 4.5.

Same here: Auto generated lightmap density not showing - Rendering - Unreal Engine Forums

hmm, it’s a bug?


This appears to be a bug and I have entered a report for it (Jira - 4451).

Thanks for reporting this!


4.6 this bug is still there…

Yes it’s still present in 4.6. It hasn’t been fixed yet. I will update this post and the AnswerhHub post once a fix has been submitted and verified. This may not be resolved for several releases and is dependent on developer priorities. Thank you for your patience.


Hi Alonezhby,

I wanted to update this thread since this issue was reported back as “won’t fix.”

The dev has looked at the reported issue and says that this is an intentional thing so this won’t be fixed.

Although, if you build lighting after the auto generated lightmap has been created this will then show the lightmap density.

After the lightmap has been generated before light build:

After light build:

Thank you!


Sorry, but I don’t get why this is an intentional thing… Maybe it was causing some sort of performance issue in the editor?

Because not being able to adjust lightmap resolution while seeing the density feedback in real time really kills a big part of the Lightmap Density View vantages for me. If I have a lot of meshes and I’m trying to optimize the lightmap resolution of every new mesh I’m adding in the scene, now I need to guess what resolution will bring uniformity with the other meshes near it, change the resolution and build light for the whole scene… This wouldn’t be so complicated if my scene wasn’t taking more than 6 hours to build light…

It would be nice if it was at least an option to “build lightmap density view” and wait a little for the editor to create those tilled colored maps…

PS. The gray texture doesn’t appear just on the auto generated lightmap, it appears on every mesh that has its lightmap resolution changed after build light, being it auto generated or not.

I agree, that was really great functionality. now we have to guess, build, guess again, build… if it wasn’t performance issue - now it is. it takes much longer to adjust lightmap resolutions. please consider enabling it again…

Please re enable this feature, as that’s what it was a really useful feature, you could judge the lightmap density without having to build after each time, it’s taking me longer to get the right balance between looks good and runs well without performance drop.