Lightmap artifacts on large mesh

I am woking with UE4 for a few days now, have been reading a lot of documentation and watched all the videos I could find, but still struggling with one thing … light maps.

First of all I only want to do archviz work so no game stuff whatsoever.
probably no need for Blueprints just some moving camera shots.
My meshes come from Lightwave, I apply UV texture coord as well as lightmap UV in Lightwave.
The only method I know and use in Lightwave for creating a lightmap is called atlas mapping and is automated.

However because lightmap UV should be within 0-1 range for larg(er) meshes the resolution will soon get to small, for small meshes I don’t have a problem but my main building keeps getting ugly splotches and artifacts along the seams of the inner walls. I tried things like upping lightm][1]ap resolution for the building mesh (even up to 2048!) or splitting things up in smaller meshes (which isn’t very convenient) but even then I can’t seem to get clean lighting solution.

How to get nice clean lighting?

Well if no one can answer my question or give any directions I am afraid I will have to cancel my subscription.
No use for software I get stuck with.

Was lightmap generated by engine? Also I’m not sure, that 2048 is enough for so huge mesh. Also splitting meshes to modular pieces and setting lightmap resolution for every piece to something about 128 should work fine, lighting also should be builded in the production quality.

Lightmap was generated in Lightwave. I haven’t tried higher Lightmap resolution as I understand that 2048 is already out of range (normally).
I tried splitting my building into smaller parts but that didn’t work.
Lighting build in production quality also contained artifacts.

Can you show your lightmap UV or attach your mesh? You can try also Distance Field Soft Shadows in Unreal Engine | Unreal Engine Documentation if you don’t like lightmapping.

Thanks gonna give that a try and upload my mesh/lightmap UV

link text

Well, I have the same issue, with properly unwrapped UV(even realistic rendering example in marketplace has issues like yours, you can easily check it), however dynamic GI solution, which I mentioned above, gives me acceptable results, just give it a shot.

Thank, quite busy right now but surely gonna give it a try!

Lightmapping is tricky business but when done right it gives you remarkably good results. First rule to follow is pretty simple, NEVER autogenerate your lightmap! When building lightmaps you need to separate every piece that is facing in a different direction, otherwise you get mad light bleeding. Also keep in mind to leave at least 4px space between each uv shell to avoid artifacts. Which i think is the case with your lightmaps, there is just noc room between the shells. I don’t know if lightwave has a similar option but in maya you can pack your uv’s with a mapsize of 64px which pretty much ensures that you have enough room between the shells.

Hmmm the point is I would like to do some archviz work (after seeing stuff done by Koola) but if that means spending hours getting my Lightmap UV’s right that would definitely be a dealbreaker. Quick (and dirty) way in Lightwave is using atlas mapping (generating result as shown above). In fact I don’t know how I would have to create Lightmap UIV’s otherwise. By hand would be very tedious and time consuming.
Having a 4px space would still mean that map size for smaller wall parts would be far too small?

You’ll get the same issue even with correctly unwrapped lightmap. Lightmass just doesn’t work as it should in some cases. I saw fully correct lighting only when scene doesn’t have dark places. Many examples in the marketplace have problems with shadows.

Normal lightmapping even when creating a decent lightmap doesn’t give me anywhere near results.
So tried the Ray Traced Distance Field Soft Shadows technique but can’t seem to find the required settings. Anyone shed some light?

Firstly, use this tutorial https://docs.unrealengine.com/latest/INT/Engine/Rendering/LightingAndShadows/LightPropagationVolumes/index.html
, then set CSM distance to zero, then follow ray traced shadows tutorial, and you’ll be ok. Also, according with your screenshots, you’re using old version of unreal engine, you have to download 4.5.1

I had the same problem, check this out https://answers.unrealengine.com/questions/107324/static-lighting-level-scale-setting-low-values-cre.html
Also doing archviz.

I know this a long time ago, but if you haven’t figured out yet … Just cut the mesh up in pieces. Generally large meshes needs way larger lighmap resolutions. Don’t keep the entire house as one mesh, cut all the walls up in smaller pieces, cut all the roofs and floors into pieces. But keep the pivot point the same so you can more easily place them.