Download

LIghtmap Artifacts (Non modular scene)

Hi, I’m new to Unreal Engine and I’m getting artifacts everywhere whenever i generate the lightmaps, my scene is not modular and it’s a big interior.

The thing is I’ve no clue on how to solve it, here’s an image:

That’s from a dome i’ve got, it’s a single piece, lightmap was generated using blender, the thing is, I could go full dynamic lighting but that would be dumb and this error is happening on every single object in my scene, that was just an example.

Any solutions to this? What am I missing?

Also, is there a way to light a huge interior with no windows? Here’s the scene in blender, that red dot in the middle is 2M tall. For now i just increase like crazy my light intensity but some areas and objects still appear dark, specially the metallic ones.

Hi!

I’m guessing you’re using an automated flat mapping and it breaks up your dome by polygon!
Try to generate manually your lightmap keeping smooth surfaces/polygons together! That will give you an even lighting resolution!
…or you can try a lot higher lightmap resolution but…

Yeah, blender’s “Lightmap” unwrap is actually very unsuitable here: it creates separate islands for each polygon which leads to artifacts when baking (even with high res lightmaps). You need to decide where to put the seams where they are least visible and unwrap. Have a loot at the default unwrap of a sphere for inspiration. Usually I’m getting decent results with Smart UV Project as well, but not so much on round objects like your dome.

One way to brighten the interior is to increase Diffuse Boost on materials / meshes. But I’m not sure how to do it in bulk, only per actor / material. It’ll probably do better with a lightmass importance volume and a post process volume that surrounds it on the exterior while having a large blend radius (or Unbound if it works with the rest of the scene) and enhancing GI and auto exposure settings.