Download

Lighting

In my game the lighting is deferent then the edit mode, why is this.

In your viewport, upper left area, when you click on “Perspective”… In the drop down… At the bottom… it says “use Game settings”…, is it ticked on or off?
There you can choose a different exposure setting, than is apllied by Default when going in to “game mode”/Rendering/capturing… … Same applies to when you use a post process volume where you set eye Adaption or other exposure settings… If “game settings”(like mentioned before) is set to off, you’ll not see the effect by the post process(or even cine Cam actor) regarding exposure…

At least what I see here looks like what I described…
If thats not the issue… Then… More context pls… What is your light setup? :grimacing:

Game setting was click on. I try both setting it still did not fix the problem.
This are all the light setting i have.






Thanks for your help.

Most prob caused by auto exposure.

At the bottom of the list of settings in details panels of actors (directional, skylight, lightmass importance volume, post process volume), there’s a heading called “Actor” which contains “Spawn Collision Handling Method”. It’s currently set to ‘…Don’t spawn if still colliding’, so when you press Play and each one is colliding with something else (overlapping) it’s going to not spawn. Set it to ‘ignore collision’ or ‘still spawn even if colliding’. That may fix the problem.

Otherwise, what are the auto exposure settings in the post process volume? Do you have any Show Flags changed from defaults (show flags are in the dropdown list at top of viewport called “Show”)?

I try it but it did not work, but this is my setting in the view area tool bar.
light6
Thanks for everybody help.

Game View has a different lighting sometimes than the in-editor view. It could be the tonemapper is set differently for game view than how it is in in-editor. The Show dropdown is the one in your screenshot a few over from the one you showed. It’s next to Lit, the lighting type dropdown. So, click Show and scroll down to Post Process to reveal the options there. At the bottom of the list is Tone Curve and Tonemapper. Try disabling / enabling, the opposite of what it’s at currently, and see if it causes the same problem or resolves it in-editor.

Sorry for late reply.
I try those and still nothing.
I forgot to mention that the background is a Material.

I thank what ever the problem is, it deal with the material lighting.
Im going to study more into it, if you know what it might be, please let me know.
Thanks for every good help.
And Marry Christmas.

It looks like it could well be something in the material, how the nodes are set. The last Lerp in the graph before plugging it all into Emissive is blending from the top set of nodes with all the nodes based on the bottom set of nodes. That doesn’t look correct. But I’m not sure how you intended to do things. What is the 3PointLevels node for exactly? The New Middle Value on it is at .05, whereas I think it might be .5 which is better? I don’t know.

Have you tried setting the material to Lit (Shading Model)?

I figure it out, at least the best I can do.
I used a Material Instance for how bright the stars
should be.
when the game load up, it did not load this material
instance.

So I decided to not use it instead add floats in its place in the regular star material.

Now I just have to add the same number in the change it until it looks like what I wont.

BINGO!

I wont to thank every body who help me in this problem, it means a lot when there people out there willing to dedicate there time to help a stranger.

THANKS EVERYBODY YOU ARE THE BEST.

                         END OF LINE

                                  :smiley: