Download

LIghting won't build anymore

I have a large terrain which was never a problem for light building,and a large imported FBX mesh,lighting seems very stuck at 0% and wondering what would cause this ? ( mesh has a cave system but its only 128K )

thx
nl

-check if you have a lightmass importance volume in your level
-open “swarm” (icon in the systray) and check if it is still moving :slight_smile:

WeLL, I waited longer this time, and it did finally build…took way longer than Ithnk it should have, given having them in a scene, is supposed to lower build time right ?

Anyway, after lighting was done, my ‘mesh’ ( on top of terrain) is all black, and it was suggested that I check for amb. occlusion that might be causing this, but I see no such setting,where is it ?

also, would the fact that this mesh has no 2nd UV lighting channel, be causing it to turn all black after a light rebuild, where before it was not all black ?

Thx so much
nl

Normally the missing 2nd uv channel is causing the black mesh. When you add a lightmass importance volume, it will lower the build time

Ok I’ll add the second channel and then see if that fixes build times, which it prob.will;)

ty
nl

No luck, 2nd channel made no diff.because its not even showing up as ‘two’ channels in object browser window.

I got it working in maya thanks to friends help, but the lighting is terrible as I forgot to match ue4 to maya grid info so I’ll fix that later and see if it helps any, but at least it was working fine inside maya.

Check your cave static mesh properties and see if you have set a good lightmap resolution according to the size/complexity of your cave. Also do check if in the properties the lightmap UV index is the right one.

You should check if your lighmaps UV’s are unique too (no overlap).

I am way too knew at this, to have much of an idea how to proceed with your instuctions. I’m just not quite that far along yet to grasp most of that.

I am sure there is no overlap, because rebuilding light gave no errors,and I used island setting in blender of .001,as a tutorial I found said to use.

Can you elaborate on the rest please ?

ty
nl

lightmap resolution -> can be set in the static mesh editor -> quality of the shadows
lightmap uv index -> you can change it in the static mesh editor -> to 1

"By default, the first set of UVs (index 0) of a static mesh will be used when generating lightmaps for static lighting. This means the same set of coordinates that is used for applying materials to the mesh will aslo be used for lightmaps. This is quite often not ideal. One reason for this is that the UVs used for generating lightmaps need to be unique, meaning that each face of the mesh must not overlap any other face within the UV space. "

So it’s still black after you have rebuild the light? + create a 2nd uv channel like in this video: http://www.youtube.com/watch?v=z5yc-bKbHyc (not the best way, but after that we will see if it was the 2nd uv). Do you use roughness/metallic in your material?