Download

Lighting too bright inside...

Why is it too bright inside of enclosed spaces in my games? I have a normal skysphere (the one already initialized in every template from the beginning), (for now) i’m using normal BSP objects (with starter content materials) yet my levels seem to be reflecting a huge amount of light (even when enclosed). While most of the level i’m making takes place outdoors and in the open, this section (and probably a few more like it in the future) will have DARK, enclosed sections. Please help! Thank You!

This thread isn’t allowing me to post/upload pics for examples.

Eye adaptation maybe. Try to disable or tweak it in post-process volume.

Taking a blind stab in the dark here (puns, puns, puns), but do you happen to have a skylight? If so, either delete it or set it to movable and play around with the settings for the skylight (to use DFAO for shadowing).

Static or stationary skylights light up the scene uniformly without regards to occlusion, so even if you have a room that is enclosed on all sides with no possible way for light to get in, the skylight will still light it up. This works wonders in a solely outdoors or a solely indoors level, as you can tailor the skylight to work for that specific level, but a mix out outdoors and indoors I don’t think can be done with static or stationary skylights. Skylights are typically used to brighten up shadows, without them shadows are pitch black, with them shadows are a bit brighter and more realistic, faking bounce lighting to brighten the shadows up a bit.

Movable skylights use DFAO for dynamic skylight shadowing, so you could use this to have the skylight work outdoors, but have things shadowed indoors. DFAO is kind of iffy in quality, though, so keep that in mind. My testing with DFAO in UE 4.9.2 (have yet to update to 4.10) shows that with default settings it’s fairly blotchy, but messing around with the settings can make it smoother. Though the problem is these settings seem to reduce occlusion, so shadows are less accurate.

Or, you can delete the skylight entirely and have pitch black shadows. And if you want, enable Light Propagation Volumes (there’s a document on LPV in Unreal’s documentation) and mess around with the settings to get some simple, cheap and inaccurate global illumination that will brighten shadows up a bit, and works (mostly) in both outdoors and indoors scenes (light leaking is a thing, though if you play around with the LPV settings in a post-process volume you can reduce light leaking as much as possible).

Otherwise, eye adaption can be a factor too. I had to adjust my eye adaption settings to stop it from over-exposing in dark environments.

So far deleting the skylight altogether has worked the best but it does come at obvious drawbacks (the biggest one being that the outside of the structure is now also entire dark.)

Unfortunately, the only ways around that would be LPV, which LPV only works within a certain volume around the player, outside that GI isn’t even computed, and unfortunately that volume is about 5000x5000x5000 units in XYZ, with the player in the centre, not large enough to encompass an entire building. You could also give DFAO a try, add a movable skylight to the scene.

Imgur