Download

Lighting rendering shadows not including total shadow

For some reason, my shadowing is treating individual objects next to each other as individual objects, and not rendering shadows by calculating how close they are.

I am trying to develop a building structure that is modular by using static meshes as walls and stuff, but for some reason each static mesh is being rendered differently. as you can see from front to back each wall is rendered a different value. and the occlusion is centered on EACH mesh instead of all the way across. I have each mesh butt up against each other, but i don’t know if this is being caused by AO settings, Lightmass, or what…

Any Ideas? Thanks!

Light is directional light set to stationary, i have a skylight and a bp sphere for skydome. all basic really…

I hope someone can help. le Bump?

EDIT: No Idea what happened, but it is fixed. I just Reimported the base mesh… ::SHRUG::

Just so you know, that’s how the Lightmass baking system works, it processes meshes individually and settings like smoothing which try to speed up rending and reduce noise by smoothing things together can create lighting variations between meshes that are supposed to look like uniform meshes. Some people have been able to reduce the effect by messing with the Lightmass settings but the best way to avoid that is to not make your meshes that way. Be conscious of what you’re making, a modular workflow is meant to reduce memory costs of meshes and keep your library small, but if your meshes are very simple (like a basic wall that has 8 vertices) then the memory saved is almost nothing and your work would be easier if you just made a unique mesh for the complete wall instead of trying to constructing it from multiple pieces.
You also want to try and reduce the number of objects overall, since draw calls are another consideration,. If you have many simple objects then it’s better to combine some of them if you can (if they use the same material for example) where you can take a bit of a hit to memory to try and reduce the draw calls.

Thanks for the advice. It must have been a lightmass setting i may have adjusted and not realized. I did up the Lightmass resolution on teh static meshes, which could also have helped. Yes I am using simple object 8 vertices boxes. Exactly, I am trying to keep my architecture library small as I am not a great modeler and is easier to think in squares and place them in the editor.

I am still learning a lot about how unreal handles stuff so your input is greatly appreciated!

Hi!

If you go under Lightmass settings with 0.1 in indirect lighting level scale (1mm accuracy) and 0.6 with Smoothness those lighting differences will disappear! BUT you’ll need to adjust quality also to get clean results and it will raise your building time by a LOT!!

Thanks for the tips!!

Unrelated but any idea why my actor isnt casting or receiving shadows?

bump on the actor not casting or receiving shadows above

Because static light bakes a lightmap, which does not respond to movable objects, and the volumetric lightmap is rather sparse.

Any advice on what is workaround?

The obvious one, not using static light for sunlight.

Well that’s the obvious one, but not what is relevant to me I THINK, since my directional light is set to Stationary and not Static… Wouldn’t that bake both static and create Dynamic shadows?

It would, in that case I have no idea. Check skylight and reflection captures?

ok thanks!