Download

Lighting quality question?

Hi all. I’ve been a Max & V-Ray user for years, and now I’m trying to learn UE4 in order to do some real-time arch viz. I’ve been following some tutorials, but I can’t figure out why I’m getting this really crappy look on my models when I build the lighting. It’s just seemingly random light and dark areas on the doors, baseboard, walls… everywhere really. It looks like it might be a light map issue, but I can’t figure out how to solve it. It’s probably something simple that I’m overlooking. I’ve tried re-mapping and unwrapping them in Max, removing smoothing groups, checking the geometry etc. I also do’t understand why I have this really chopping shadows (image 3) but this could all be related.

I’m new to Unreal, so go easy on me! Cheers:)

17de26cdb938f03c30d9376612f887791feda864.jpeg

You need to increase the light map resolution on your static meshes.

Thanks ZacD. I hit the override on the static mesh, bumped it up to 128 and it worked a treat. Is there a quick way to do this globally, so I don’t have to apply to each static mesh individually?

You can set it on a static mesh so that if effects any time that asset is placed. There’s no global setting, and you may have to use much higher resolutions than 128 on larger meshes, especially when you need detailed shadows.

So you’re saying that if I override the light map resolution once, the mesh will keep that setting each time I reimport?

If you open the static mesh from the content browser it will have a setting for the lightmap resolution. That will set the lightmap resolution for that mesh whenever you use it. If you select the object in your game level and change the lightmap override resolution then that will only apply to that copy of the mesh rather than all copies of that mesh.

Thanks guys, much appreciated.