Download

Lighting problems

I’m having some trouble getting my level to be properly lit (It drives me crazy). I’ll just show you some screens, before explaining what the problem is, that makes it a lot easier:

http://puu.sh/7QXto.jpg

http://puu.sh/7QVyS.jpg

http://puu.sh/7QY1T.jpg

http://puu.sh/7QYko.jpg

pic 1. As you can see, the tiles’ lighting is all over the place. Pretty much none of them are lit correctly. The carpets on the wall however are better. The table and the objects on it have physics enabled, but it’s still kind of wierd that there is no shadow at all, considering it’s more or less a dark room.

Note that even with the standard-UE4-tiles, the lighting is broken. This is preview lighting, but production-lighting gives me similar results.

pic 2. Pretty much the same problem as pic 1.

pic 3. This is on the example-map, so I guess it’s not my light-settings.

pic 4. the left tree is after I built the lighting, the right one before. Needless to say, that the left one is much too dark. I btw. don’t know why the terrain stopped having proper shadows. I must have changed something in my scene. Any idea what this could have been and how to revert it?

I could really use some help here, even if just a few little hints in the right direction.

Thank you in advance :slight_smile:

Make sure that your mesh has a 2nd uv channel with a proper lightmap: https://www.youtube.com/watch?v=z5yc-bKbHyc (you can also find a german tutorial on my channel ;))

Also add one of the meshes from epic games into your level to check, if either the lightning or your meshes are causing the problem

I have problems with tilled meshes for walls and floor too. I could’t find any way to fix that.

Thanks for replying!

I actually used your tutorial to create my objects’ lightmaps, so I guess they are good! :smiley:

As I said: Epic’s tiles give me the same results. I’m not sure if I explained that good enough, but normal props are for most of the part good. For some reason it is only the tiles that are broken (Whether it be the ones made by me, or by epic, both on the example-map and on my map).

I really can’t find the reason why my landscape stopped having proper shadows. Any idea on that?

Have you made those tiles with a bsp brush? (sorry, but Im a little bit confused atm what you exactly mean ;)) -> when yes, then increase the lightmap size (to e.g 128)
It could also be that the material is causing that -> create a very simple one and assign it to your mesh

For the landscape -> check if the cast shadow properties from your light are activated and probably also move/rotate the light a little bit

I didn’t create the tiles with a bsp brush. I just dragged and droped them from the content-browser into the scene. The lightmaps were on 64. setting them to 124, or even 512 doesn’t fix the problem unfortunately :confused:

When I disable and reenable “cast shadow” on the directional light, it works until I rebuild the scene.

Sorry, overlooked the material-part. It happens with every material. But only after building the lighting.

Hmm, strange.

When no one else has an answer to that, you could also add me at skype -> then I could probably help you to fix your problem :slight_smile: (nasph96 -> mostly Im online at 18:00 Austrian time ^^)

Did you try changing the light to movable?
Also might be worth re-checking the WorldSettings->Lightmass section.

You could also upload your scene so one could have a look at it. :wink: Never had issues like that.

Alright. I’ll just post a scene where you can see the problem. I included the walls. But as you can see it happens both with my walls and the walls made by Epic, both on this map and on the example-maps. So I guess the problem has something to do with the lighting.

Download:
http://www.mediafire.com/download/lx1y32m7lmx8s1s/Map_and_Meshes.rar

Thanks to fighter5347 I btw. fixed the tree. Hadn’t have a lightmap-channel for the leaves.

For future, keep the same directory structure - otherwise the map won’t load correctly :slight_smile:
It misses the materials:


Info Failed to load /Game/Materials/Material2.Material2 Referenced by Mauer_standard_01_01 Property /Script/Engine.StaticMesh:Materials
Info Failed to load /Game/Materials/Material__lightmap.Material__lightmap Referenced by Mauer_standard_01_01 Property /Script/Engine.StaticMesh:Materials
Info Failed to load /Game/Materials/Material2.Material2 Referenced by Mauer_standard_01_01_Tuer Property /Script/Engine.StaticMesh:Materials
Info Failed to load /Game/Materials/Material__lightmap.Material__lightmap Referenced by Mauer_standard_01_01_Tuer Property /Script/Engine.StaticMesh:Materials
Info Failed to load /Game/Materials/unnamed.unnamed Referenced by Boden_standard_01_01 Property /Script/Engine.StaticMesh:Materials


Your level has only one directional light, if you are trying to get the insides of the buildings lit, then no wonder it’s dark :wink:
After adding few point lights this is how the scene looks on my end:

http://files.phoboz.net/ss/lighting.png

My problem is not that the room is too dark, it’s that the lighting just doesn’t make sense.

http://puu.sh/7SdRd.jpg Notice how in between the tiles, the lighting is cut off, or the wierd back wall.

http://puu.sh/7SdRd.jpg

http://puu.sh/7Se34.jpg or here with the standard-tiles. Very similar problem (Even though I have to admit, that it’s less noticeable than with my tiles. No idea why). The light is very blocky, some tiles are lit even though they should be pitch black. Or in some corners light just comes through. The outside-walls have a similar problem. Some tiles are completely black, others aren’t and in between the tiles, there is a sharp line (Again, present with both tiles, but more apparent with my custom ones).

I don’t know how else to explain it. It’s not about the brightness, but about just how wierd the lighting looks :smiley:

edit: Or here is another example: http://puu.sh/7SeYI.jpg

Strange, I didn’t have that problem…
What material are you using for the tiles?
What happens if you switch the light to movable?
I assume this is after lighting build? :wink:
Try adding LightmassImportanceVolume and make it span just outside this room.
Paste a screen of your WorldSetting->Lightmass?

That’s it… I’m out of ideas :wink:

We have already tried to use other materials, adding/replacing the lightmass importance volume, setting the mobility to moveable, copy a full lightsetup from a template map,… But probably it’s really something in the lightmass settings

Is it just this particular project? Or is same thing happening for all your projects?

The things you mentioned above didn’t fix it. http://puu.sh/7StIf.jpg here are the lightmass-settings.

It happens in every project and on every map.

Some more generic questions:
Is this the binary release of the engine or did you build it yourself?
What graphics card do you have? Are you using the latest drivers? Beta drivers?

Alright, last thing I can think of: Select ForceNoPrecomputedLighting, switch all your lights to movable and do full build.

I downloaded the launcher and the launcher automatically downloaded it, if that answers your question. I also tried verifying the files.

I am using a GTX680 with the latest stable drivers.

Except of a too dark ceiling compared to the rest, the problem isn’t visible when I do this. As I said: It’s only visible after building the lighting. Just removing the precomputed lighting isn’t really a great solution though :confused:

No, it isn’t but I asked just to make sure that that’s where the problem lies.
As much as I hate to say it, I’m just not good enough with the engine yet to help you out :frowning:

For what it’s worth You’re not alone in having this issue. I’m trying to figure out exactly what’s up as well, as strangely, It doesn’t seem to occur in any of the tutorial videos either. :confused: